请教;步进电机驱动器的作用 点击:0 | 回复:27



恩波

    
  • 精华:0帖
  • 求助:0帖
  • 帖子:6帖 | 22回
  • 年度积分:0
  • 历史总积分:40
  • 注册:2007年3月04日
发表于:2007-08-01 22:02:00
楼主
请教;步进电机驱动器的作用
我只知道输入的量有220电,脉冲串和方向,输出的380电三相,
有谁知道他的作用,详细一点/1! 



波恩

  • 精华:11帖
  • 求助:1帖
  • 帖子:238帖 | 11029回
  • 年度积分:0
  • 历史总积分:36220
  • 注册:2003年6月12日
发表于:2007-08-01 22:06:00
1楼
作用是把逻辑控制信号(脉冲串和方向,使能等)转化为可驱动步进电机运行的功率电流。如果供电是220V,输出通常不会是380V。

另,相同内容请勿重复发帖!望配合版务。

恩波

  • 精华:0帖
  • 求助:0帖
  • 帖子:6帖 | 22回
  • 年度积分:0
  • 历史总积分:40
  • 注册:2007年3月04日
发表于:2007-08-05 14:36:00
2楼
我怎么知道我要问的问题是否重复啊?
谢谢
还有,最近我的步进电机出现这样一个问题,望斑竹赐教,我给电机通电想让他转动时,它只在原地颤抖打转,而且还发着噪音,我初步估计是驱动器坏了,但我不知道是驱动器的什么元件坏了,电子商场上是否有卖这种元件的?

新生代

  • 精华:0帖
  • 求助:0帖
  • 帖子:8帖 | 8回
  • 年度积分:0
  • 历史总积分:32
  • 注册:2007年7月14日
发表于:2007-08-05 15:56:00
3楼
会不会是驱动信号的频率太高了?

刘岩利

  • [版主]
  • 精华:2帖
  • 求助:0帖
  • 帖子:20帖 | 8089回
  • 年度积分:1199
  • 历史总积分:26632
  • 注册:2005年3月09日
发表于:2007-08-05 17:14:00
4楼
先把频率给低一点,确认以下驱动器到电机的线连接正常,再怀疑驱动器吧。至于驱动器哪里坏,可能是信号接收部分收到信号不稳定,也可能是内部处理部分,输出电流不正确,也可能是最后电流输出部分造成电机缺相,不太好猜

gongkongedit

  • 精华:1099帖
  • 求助:0帖
  • 帖子:14399帖 | 54471回
  • 年度积分:0
  • 历史总积分:579
  • 注册:2008年9月08日
发表于:2007-08-05 20:17:00
5楼
是不是增益比调节不适当

驱动

  • 精华:0帖
  • 求助:0帖
  • 帖子:4帖 | 30回
  • 年度积分:0
  • 历史总积分:71
  • 注册:2007年2月10日
发表于:2007-08-05 20:58:00
6楼
这样的情况不要...是驱动器不匹配或应该来讲是驱动器参数不匹配.电流,增益考虑清楚

北京步进

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 67回
  • 年度积分:0
  • 历史总积分:187
  • 注册:2007年7月06日
发表于:2007-08-06 16:15:00
7楼
楼上两位说得太深奥,听刘岩利老师的,接错线或断线缺相的可能性大,我们经常碰到。

恩波

  • 精华:0帖
  • 求助:0帖
  • 帖子:6帖 | 22回
  • 年度积分:0
  • 历史总积分:40
  • 注册:2007年3月04日
发表于:2007-08-08 20:27:00
8楼
谢谢各位
线应该没问题的吧,以前很好啊,用了好几个月了,那天通电用时就出现这现象了,我是两轴控制的。我用另一个轴的驱动器来驱动这个电机时他运转正常啊,线还用他的线,只是给他调换了一下驱动器,
我认为就是驱动器坏了!

波恩

  • 精华:11帖
  • 求助:1帖
  • 帖子:238帖 | 11029回
  • 年度积分:0
  • 历史总积分:36220
  • 注册:2003年6月12日
发表于:2007-08-08 20:33:00
9楼
"用了好几个月了"———别急着自己修,看看是否还在保修期或包换期内?

63794068

  • 精华:0帖
  • 求助:0帖
  • 帖子:4帖 | 7回
  • 年度积分:0
  • 历史总积分:23
  • 注册:2007年6月18日
发表于:2007-08-08 21:44:00
10楼
一般马达驱动器和马达按照图纸接好线路好遇到马达发烫的原因有可能缺相 还有驱动器可能坏掉了

恩波

  • 精华:0帖
  • 求助:0帖
  • 帖子:6帖 | 22回
  • 年度积分:0
  • 历史总积分:40
  • 注册:2007年3月04日
发表于:2007-08-10 13:49:00
11楼
步进电机没有散热装置,有时候他的表面温度很高很烫手,我担心他会不会烧坏啊

波恩

  • 精华:11帖
  • 求助:1帖
  • 帖子:238帖 | 11029回
  • 年度积分:0
  • 历史总积分:36220
  • 注册:2003年6月12日
发表于:2007-08-10 14:36:00
12楼
只要滴水不至于“爆沸”,应该还过得去。

凡夫俗子

  • 精华:0帖
  • 求助:0帖
  • 帖子:8帖 | 540回
  • 年度积分:0
  • 历史总积分:642
  • 注册:2003年11月27日
发表于:2007-08-10 16:19:00
13楼
步进驱动器的作用,主要是将脉冲信号按顺序的分配给每相,按拍节控制每相的导通或关闭,以及导通的电流方向。。。如果带细分的驱动器就是采用恒电流的控制方式,那么就还要按脉冲时序进行控制每相的电流大小,以使合成磁场按细分步移动。。。。。。这个分配的功能也有人称为环型分配功能,现在很多步进驱动芯片已经将这个功能集成,使用者只需要自己搭配外围的功率放大电路即可,功率小的放大电路也有现成的芯片集成可控制门极电路或三极管电路,功率大的就要用单独的可控制门极管或芯片来实现,一般这个器件很容易发热,所以一般都会将这个管子或芯片用导热胶贴在散热片上以尽快降温,功率大的就需要加装风扇。。。。


楼主的问题如果不是接线错误的话,就很有可能是有一相的功率放大电路的那个管子或芯片坏掉了,所以造成缺相震动。。。具体可以拆开驱动器,你的步进系统应该是混合三相的,是德国进口的百格拉的还是国产深圳白山的?

拆开之后应该能看见里面有3个或6个一样的三根脚的管子,测量哪个管子坏掉的办法是电机停止时有保持转矩时测量三相每组的输出电压,如果是类似百格拉的混合式步进,应该通常三个管子在保持时都有电压(三相的输出电流应该是各差120度的类似正弦波,所以一个周期每相只有两个点电流为0),如果有一相为0给一定数量脉冲后再测这一相的输出电压如果仍然为0,再测几个位置一直为0肯定这相的管子坏掉了。。。。按型号买一个一样的换上去就行

凡夫俗子

  • 精华:0帖
  • 求助:0帖
  • 帖子:8帖 | 540回
  • 年度积分:0
  • 历史总积分:642
  • 注册:2003年11月27日
发表于:2007-08-10 16:32:00
14楼
关于步进电机的发热问题:
首先步进电机本身就是个耗能元件,它即使在转动时有效功就是转动产生的能量比整个步进系统的输入功率来说比重也小,大部分能量都用于发热了,转动时还好些,可以将部分能量用于转化为动能了,可是静止保持时绝大部分都用于发热了。。。这么说吧,两个完全一样的步进电机系统,一个始终转动,一个处于停止带电保持状态,那后者一定比前者热很多。。。

所以一般的驱动器都会支持一个半流保持功能,就是将带点停止保持时的输出电流减为一半,当然此时的保持转矩也相应减小,可以根据工艺选择是否使用此功能来减小发热。。。

还有就是一般步进驱动器都有脱机信号,也有叫使能的,一般伺服电机系统叫使能的居多。。。这个信号的功能的功能就是在停止时可以使电机完全的不带电就避免发热了,实际使用要看工艺要求是否需要电机输出保持力矩,例如有重力或弹性负载的场合就需要输出停止保持转矩。。。。

一己之见,有误见谅

恩波

  • 精华:0帖
  • 求助:0帖
  • 帖子:6帖 | 22回
  • 年度积分:0
  • 历史总积分:40
  • 注册:2007年3月04日
发表于:2007-08-11 11:03:00
15楼
我的步近电机是北京斯达微步的(原名斯达特机电),

凡夫俗子

  • 精华:0帖
  • 求助:0帖
  • 帖子:8帖 | 540回
  • 年度积分:0
  • 历史总积分:642
  • 注册:2003年11月27日
发表于:2007-08-11 14:45:00
16楼
客观的说,斯达特的步进也是国内品牌里比较出色的,但他们的混合三相与百格拉的混合三相略有不同的是,百格拉采用的是类似交流电机的3相正弦波的PWM控制方式,对每相的正弦波进行细分斩波,所以细分的步数就是由这个斩波的个数来决定的,而且矩频特性也类似交流电机的恒转矩输出一样,输出转矩在一定氛围内能保持大体一直的输出;;;

斯达特的混合步进应该是来源于美国的技术,因为他们是留美博士回国创业,做的时间也比较长,成立于90年代初期,那时国内最早的两家做步进系统就是斯达特和四通,四通现被和利时收购。。。
具体斯达特的驱动器你采用我上面说的:在不同停止保持点测量每相的管子输出是否正常也一样能找出你的问题所在,如果每相的管子都没问题,那估计控制芯片可能出现损坏了。。。

wuyongdai

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 5回
  • 年度积分:0
  • 历史总积分:5
  • 注册:2008年2月01日
发表于:2008-03-10 21:05:00
17楼
我的130BC3100A步进电机只有一个方向运动,把线头调换后还是一个方向,且方向和没调换前是一样的,问那里有毛病啦

gaodong12

  • 精华:0帖
  • 求助:0帖
  • 帖子:4帖 | 96回
  • 年度积分:5
  • 历史总积分:350
  • 注册:2005年3月24日
发表于:2008-03-10 21:31:00
18楼
和伺服驱动一样,只是步进是开环的,驱动电机用的.

刘岩利

  • [版主]
  • 精华:2帖
  • 求助:0帖
  • 帖子:20帖 | 8089回
  • 年度积分:1199
  • 历史总积分:26632
  • 注册:2005年3月09日
发表于:2008-03-10 21:56:00
19楼
把线头调换后还是一个方向
怎么调换的?

wuyongdai

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 5回
  • 年度积分:0
  • 历史总积分:5
  • 注册:2008年2月01日
发表于:2008-03-24 19:44:00
20楼
我的130BC3100A步进电机只有一个方向运动,把线头调换后还是一个方向,且方向和没调换前是一样的,问那里有毛病啦
    我的问题是,我把运动卡上的两个信号线,红和黑,
 先把红接cp,黑接mc.
   我按"上"方向有运动
     我量一下电压cp4.5V,mc0V.
    我按"下"方向没有运动。
      我量一下电压cp0V,mc4.5V

再把黑接cp,红接mc
    我按"下"方向有运动
      我量一下电压cp4.5V,mc0V.
    我按"上"方向没有运动。
      我量一下电压cp0V,mc4.5V
我现在不知道是那里有问题

相关主题

官方公众号

智造工程师
首页 上一页 1 2 下一页 尾页