Advertisement
当前位置:
求助:伺服电机控制
回复 | 人气 | 打印
king0815 个人主页 给TA发消息 加TA为好友 发表于:2007-04-12 21:54:00 楼主
请教各位高手,我们有台力士乐系统的机床,各轴运行正常,但有一天出现其中一个轴(Z轴)运动距离比平时多出十几毫米,就是原来Z轴走刀120mm,现在走的距离比原来多出10mm,但程序中显示还是120mm,请教各位大哥这是什么原因?
分享到: 收藏 回复 举报
波恩 个人主页 给TA发消息 加TA为好友 发表于:2007-04-13 10:25:00 1楼
  走的是相对坐标量还是绝对坐标量?建议首先请确认Z轴原点是否改变?
  回复引用举报
自动化983 个人主页 给TA发消息 加TA为好友 发表于:2007-04-13 18:38:00 2楼
  只要每次120mm都是这个位置的话就没有问题,不会是误差的,这么大的误差估计早就报警了。
  回复引用举报
king0815 个人主页 给TA发消息 加TA为好友 发表于:2007-04-13 18:54:00 3楼
  电机走的是绝对位置. Z轴原点没变,退回0点时位置是在原位.

这个120mm是机床Z轴向前走的对刀位置,以前走120mm就没事,但现在什么也没变走120mm就会多走,出现撞刀.

但是现在我把对刀位置由120mm改为110mm,其它什么也没变,机床就正常了,不会撞刀了.

让我不明白的是这会是什么原因引起的呢???
  回复引用举报
刘岩利 个人主页 给TA发消息 加TA为好友 发表于:2007-04-13 19:56:00 4楼
  有没有人动过参数?
  回复引用举报
波恩 个人主页 给TA发消息 加TA为好友 发表于:2007-04-13 21:25:00 5楼
  “电机走的是绝对位置. Z轴原点没变,退回0点时位置是在原位.”是不是什么有参数会改变内部原点的偏置值。

“把对刀位置由120mm改为110mm,其它什么也没变,机床就正常了”,刀具半径是否有所变化呢?另外工件位置有没有变化?
  回复引用举报
盛健 个人主页 给TA发消息 加TA为好友 发表于:2007-04-14 14:37:00 6楼
  编码器的零位检测出错,少检测了一个零位信号.
  回复引用举报
踏沙行 个人主页 给TA发消息 加TA为好友 发表于:2007-04-14 23:53:00 7楼
  同意楼上的.还是重点怀疑编码器反馈上....应该确认编码器是不是信号有些变化.....不知道你用的是什么反馈传感器.可以说下么?
  回复引用举报
king0815 个人主页 给TA发消息 加TA为好友 发表于:2007-04-21 16:13:00 8楼
  反馈用的是伺服电机带的编码器. 可能是编码器出错了.
  回复引用举报
牛牛牛 个人主页 给TA发消息 加TA为好友 发表于:2007-04-22 10:14:00 9楼
  检查一下刀具参数,可能与直径编程还是半径编程有关
  回复引用举报
FX系 个人主页 给TA发消息 加TA为好友 发表于:2007-04-22 21:48:00 10楼
  我这里经常出现那样的问题,间断性的出现,如果重新回原点,又可以了,有时要回几次原点才可以,根据我个人的感觉应该是原点信号有变动,有时调一下要管很长一段时间,不知是否这样,不要砸我
  回复引用举报
linfuhao2003 个人主页 给TA发消息 加TA为好友 发表于:2007-04-23 00:23:00 11楼
  不一定
更换一下反馈线
屏蔽线连接不好也会出现这中情况
Z轴有光栅尺没有?
  回复引用举报
控制控制 个人主页 给TA发消息 加TA为好友 发表于:2007-04-24 22:17:00 12楼
  编码器出错为什么到110mm就没问题呢?你在试试别的数值 比如在大点或者小点,但要在不撞刀的情况下,如果只在120mm出问题那就说明问题了.
  回复引用举报
波恩 个人主页 给TA发消息 加TA为好友 发表于:2007-04-25 16:30:00 13楼
  “伺服电机带的编码器”是绝对式的?还是增量式的?
  回复引用举报
参数错误 个人主页 给TA发消息 加TA为好友 发表于:2007-04-25 20:48:00 14楼
  看你的到库表参数,半径补正或坐标偏移,和别的没关系,系统要出那样的错误,你可以拿个榔头砸了,呵呵.是人为的原因了
  回复引用举报
右手 个人主页 给TA发消息 加TA为好友 发表于:2008-04-11 17:16:48 15楼
 

倾向于某些参数被人为改动过了.建议详细检查下参数设置!

  回复引用举报
zwm00306 个人主页 给TA发消息 加TA为好友 发表于:2008-04-30 10:59:54 16楼
  448036217@qq.com
  回复引用举报
羊皮狼 个人主页 给TA发消息 加TA为好友 发表于:2009-09-22 12:02:58 17楼
 

以上都不对路,首先这个问题不在编码器上,也不是原点问题,我建议首先检查仿真输出线有没有破损,可能的话更换仿真输出线,其次你看你的地线附近有没干扰,再次你的机械有没有问题。

  回复引用举报
日发机械 个人主页 给TA发消息 加TA为好友 发表于:2010-02-28 19:38:20 18楼
  版主,博世力士乐的系统能用其他公司的伺服驱动器和电机吗,是SERCOS接口的。国内有能匹配使用的吗?
  回复引用举报
daysummer 个人主页 给TA发消息 加TA为好友 发表于:2010-03-01 12:48:21 19楼
  用过别的系统带力士乐的,力士乐系统应该也能带别的,sercos协议就行。
  回复引用举报
SinoRyan 个人主页 给TA发消息 加TA为好友 发表于:2010-03-01 13:21:44 20楼
 

也可能是机械方面的问题

  回复引用举报
孤独的小兵 个人主页 给TA发消息 加TA为好友 发表于:2010-04-01 09:57:53 21楼
 

肯定是机械问题啊,你回零一次,肯定不在零点

  回复引用举报
a123456abcCBA 个人主页 给TA发消息 加TA为好友 发表于:2018-07-11 17:09:25 22楼
 

来看看评论,

  回复 引用 举报

相关主题
周点击排行
周回复排行
    最新求助
      Advertisement Advertisement