求助:伺服电机不给脉冲,偶尔也会转一点 点击:0 | 回复:17



书山有路-勤为径

    
  • 精华:0帖
  • 求助:4帖
  • 帖子:15帖 | 88回
  • 年度积分:1
  • 历史总积分:763
  • 注册:2010年10月23日
发表于:2011-04-29 09:09:46
楼主

我用的是台达EH系列PLC控制松下伺服电机,Y0是脉冲,因为Y0和Y1公用C0,所以我没用Y1做为控制方向,而用Y15是控制方向。伺服脉冲输入采用长线驱动输入,要求用差分输入,因为我手头没有差分输入电路,所以,我直接用Y0和C0接了PULSH1和PULSH2。而SIGNH1和SIGNH2我用了PLC控制中间继电器换相(正转时,SIGNH1-SIGNH2=5V;反转时,SIGNH1-SIGNH2=-5V),伺服ON接的是Y10。伺服上面就接了这些个线。

问题是:系统给电后(不给脉冲),伺服偶尔会爬行一点(很少,大约1/100转),请问这是怎么回事呢?会不会是因为干扰?

补充:此柜子里还有个变频器。可是我该用屏蔽双绞线的我都用了,该接地的我就接了。




书山有路-勤为径

  • 精华:0帖
  • 求助:4帖
  • 帖子:15帖 | 88回
  • 年度积分:1
  • 历史总积分:763
  • 注册:2010年10月23日
发表于:2011-04-29 09:16:40
1楼

再补充一下:发指令可以按部就班的运动,可能是因为上述原因,运动距离不是很准,比如正转10圈后再翻转10圈,此时的位置就跟初始没转之前的位置有小小差异。

aiboer

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 1回
  • 年度积分:0
  • 历史总积分:11
  • 注册:2011年1月10日
发表于:2011-04-29 09:48:10
2楼

接线似乎不对啊 c0和y0之间不用接24电吗

晶体管输出不是差分的5v  所以应该是缺个24v电

 

treeglow

  • 精华:0帖
  • 求助:4帖
  • 帖子:10帖 | 35回
  • 年度积分:0
  • 历史总积分:311
  • 注册:2008年7月14日
发表于:2011-04-29 20:27:15
3楼
伺服电机的刚性调了吗?是不是刚性太低了?

刘岩利

  • [版主]
  • 精华:2帖
  • 求助:0帖
  • 帖子:20帖 | 8089回
  • 年度积分:1699
  • 历史总积分:27132
  • 注册:2005年3月09日
发表于:2011-05-01 21:29:27
4楼
问题是:系统给电后(不给脉冲),伺服偶尔会爬行一点(很少,大约1/100转),请问这是怎么回事呢?会不会是因为干扰?

我觉得,干扰的可能性比较大.

wjbgk

  • 精华:0帖
  • 求助:0帖
  • 帖子:17帖 | 210回
  • 年度积分:0
  • 历史总积分:2829
  • 注册:2002年3月08日
发表于:2011-05-03 09:51:17
5楼
可能是干扰的问题,或者整定的参数不够好吧

刘岩利

  • [版主]
  • 精华:2帖
  • 求助:0帖
  • 帖子:20帖 | 8089回
  • 年度积分:1699
  • 历史总积分:27132
  • 注册:2005年3月09日
发表于:2011-05-03 17:20:06
6楼

“我直接用Y0和C0接了PULSH1和PULSH2。”

不发脉冲的时候,PULSH1和PULSH2分别是什么电器状态?

书山有路-勤为径

  • 精华:0帖
  • 求助:4帖
  • 帖子:15帖 | 88回
  • 年度积分:1
  • 历史总积分:763
  • 注册:2010年10月23日
发表于:2011-05-03 18:41:39
7楼
回复内容:
对:刘岩利 关于

“我直接用Y0和C0接了PULSH1和PULSH2。”

不发脉冲的时候,PULSH1和PULSH2分别是什么电器状态?

内容的回复:

刘工,不发脉冲时都时应该都是低电平。

书山有路-勤为径

  • 精华:0帖
  • 求助:4帖
  • 帖子:15帖 | 88回
  • 年度积分:1
  • 历史总积分:763
  • 注册:2010年10月23日
发表于:2011-05-03 18:49:52
8楼
回复内容:
对:刘岩利 关于

“我直接用Y0和C0接了PULSH1和PULSH2。”

不发脉冲的时候,PULSH1和PULSH2分别是什么电器状态?

内容的回复:

我感觉也可能是干扰,可是我该接地的都接地了(伺服地,PLC地),该用双绞屏蔽线的都用双绞屏蔽线了,唯一没做到的是:伺服电源输入端没加噪声滤波器、磁力接触器和电抗器,我以前做的也都没加这些,都没出现过这种情况。我真不知道该怎么做了。

fork

  • 精华:1帖
  • 求助:0帖
  • 帖子:16帖 | 160回
  • 年度积分:0
  • 历史总积分:1156
  • 注册:2004年8月28日
发表于:2011-05-03 23:01:48
9楼
楼主你要用示波器检查给定脉冲信号波形,伺服电机输入电源的波形;

Piston

  • 精华:2帖
  • 求助:1帖
  • 帖子:149帖 | 13110回
  • 年度积分:63
  • 历史总积分:39969
  • 注册:2009年5月22日
发表于:2011-05-03 23:26:15
10楼

观察下上电就动时是否就有脉冲信号?可能是干扰信号所致

刘岩利

  • [版主]
  • 精华:2帖
  • 求助:0帖
  • 帖子:20帖 | 8089回
  • 年度积分:1699
  • 历史总积分:27132
  • 注册:2005年3月09日
发表于:2011-05-04 06:42:54
11楼
回复内容:
对:书山有路-勤为径 关于回复内容:

刘工,不发脉冲时都时应该都是低电平。
内容的回复:


我不知道你有用的是哪种松下,脉冲接口是是真的差分接口还是光耦接口。如果是真的差分接口,这样处理确实危险很大的。差分接口是以压差为正或为负区分逻辑状态的,例如RS422标准,压差大于0.2V和小于-0.2V分别表示两种逻辑状态。压差在=/-0.2V之间为不确定状态。如果两根线都是低电平,压差几乎为0,这种状态上稍有风出草动就是不可承受的干扰。 

zlzxw

  • 精华:0帖
  • 求助:0帖
  • 帖子:12帖 | 768回
  • 年度积分:1
  • 历史总积分:2197
  • 注册:2004年7月05日
发表于:2011-05-04 11:37:24
12楼
只能是开路集电极接法,没有差分一说用这种plc来说,看看说明书看看线接的对不对。

建议删除该帖

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 580回
  • 年度积分:0
  • 历史总积分:2884
  • 注册:2010年9月08日
发表于:2011-05-04 11:57:28
13楼
不给脉冲偶尔转一下还好,就怕不给电也偶尔转一下:)

书山有路-勤为径

  • 精华:0帖
  • 求助:4帖
  • 帖子:15帖 | 88回
  • 年度积分:1
  • 历史总积分:763
  • 注册:2010年10月23日
发表于:2011-05-13 15:03:20
14楼

我终于弄懂了,普通PLC的脉冲输出只能通过集电极开路形式输入到伺服驱动器的普通光耦输入电路接口,而不能输入到差分输入专用电路接口。

在此对各位朋友的热心赐教表示感谢,特别是咱们的刘版主,再次表示感谢!

sdw450767428

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 4回
  • 年度积分:0
  • 历史总积分:54
  • 注册:2010年6月07日
发表于:2011-08-22 21:31:30
15楼

我前段时间用了松下A4伺服驱动器,但是由于惯量比设置的不合适,导致上电后伺服电机抖动,由于抖动反馈到伺服驱动器显示有速度输入,我以为是干扰的问题,想把集电极开路形式改为差分输入形式,但是查了相关资料三菱plc没有差分输出功能只能用集电极开路形式,所以调整参数后就不再抖动.现在还不知道什么样的PLC有差分输出形式的? "书山有路-勤为径"了解不?

lxf1314

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 70回
  • 年度积分:0
  • 历史总积分:452
  • 注册:2011年7月31日
发表于:2012-02-07 09:36:29
16楼

伺服偶尔会爬行一点,这个说明就不太可能是干扰了,如果是有干扰,你就算不给脉冲,也应该会一直小小的爬行的!

这种情况我认为是"偷跑",你将速度控制的OFFSET值清0再试试看,理论上应该好了!我们的伺服是Pr52,松下的好像也是了!欢迎交流:Q:2238262396,李工

aaxiaobai

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 3回
  • 年度积分:63
  • 历史总积分:63
  • 注册:2020年1月03日
发表于:2020-01-06 10:42:48
17楼


回复内容:

对: lxf1314 伺服偶尔会爬行一点,这个说明就不太可能是干扰了,如果是... 内容的回复!

-------------------------

松下a5伺服驱动器如果不给使用plc等上位机输入脉冲,可以工作运转吗


相关主题

官方公众号

智造工程师