请教:关于伺服电机抖动 点击:0 | 回复:22



szllc

    
  • 精华:1帖
  • 求助:0帖
  • 帖子:40帖 | 220回
  • 年度积分:0
  • 历史总积分:351
  • 注册:2004年9月15日
发表于:2004-12-20 13:33:00
楼主
各位大虾: 我在使用松下伺服电机的过程中,用手摸在电机的连轴器上,会清晰的感觉得到连轴器的抖动。 您在使用过程中会感觉得到抖动吗?抖动的幅度有多大? A.清晰,甚至有些麻手。 B.能感觉得到,但不太明显 C.很不明显,几乎感觉不到 另问:这是什么原因造成的?与控制器有关还是与电机本身有关?应如何改变这一状况?



ccbq

  • 精华:0帖
  • 求助:0帖
  • 帖子:3帖 | 558回
  • 年度积分:0
  • 历史总积分:581
  • 注册:2003年9月26日
发表于:2004-12-20 13:45:00
1楼
电机的问题。电机质量不好就会这样,准确的说是质量控制不稳定,也许换个电机没准就很稳。与控制也有关系吧,多数情况是电机的问题。

szllc

  • 精华:1帖
  • 求助:0帖
  • 帖子:40帖 | 220回
  • 年度积分:0
  • 历史总积分:351
  • 注册:2004年9月15日
发表于:2004-12-20 14:09:00
2楼
ccbq:你好。 可是我有3个伺服电机都有类似现象啊?不可能电机质量都不好吧?你碰到过类似现象吗?如何消除的?

ccbq

  • 精华:0帖
  • 求助:0帖
  • 帖子:3帖 | 558回
  • 年度积分:0
  • 历史总积分:581
  • 注册:2003年9月26日
发表于:2004-12-20 16:07:00
3楼
是这样,有一次试验用进口驱动器带国产电机,低速时都有不同程度的抖动。有一台电机特别明显,另一台不仔细看还可以,把手放上去也能感觉到,不过这种抖动已经能接受了。所以我认为是电机问题。当然也不排除有时驱动器调的不好造成抖动。请仔细观察抖动发生的情况,是否相同,在哪一工作段,再分析原因。

szllc

  • 精华:1帖
  • 求助:0帖
  • 帖子:40帖 | 220回
  • 年度积分:0
  • 历史总积分:351
  • 注册:2004年9月15日
发表于:2004-12-21 10:28:00
4楼
我的驱动器及电机都是松下的。 控制板是gt的。 那驱动器参数应该如何调才算好呢?

TellTruth

  • 精华:1帖
  • 求助:0帖
  • 帖子:16帖 | 451回
  • 年度积分:0
  • 历史总积分:1302
  • 注册:2003年10月29日
发表于:2004-12-22 09:25:00
5楼
振动多半是PID参数没调好,电机振荡。 不能以空载的参数应用于负载时的情况。 松下有它的调试软件(串口通讯方式)。

szllc

  • 精华:1帖
  • 求助:0帖
  • 帖子:40帖 | 220回
  • 年度积分:0
  • 历史总积分:351
  • 注册:2004年9月15日
发表于:2004-12-22 11:27:00
6楼
各位高人:我使用了电机的jog自运行方式,发现电机还是抖!这说明什么问题? 这个都是用眼睛看不出来的,用手摸在电机轴上才会感觉得到。

nick1978

  • 精华:0帖
  • 求助:0帖
  • 帖子:2帖 | 58回
  • 年度积分:0
  • 历史总积分:164
  • 注册:2003年7月25日
发表于:2004-12-24 15:32:00
7楼
1、从机构上看你是否安装合理,即电机轴与负载轴是否同轴? 2、增益设置是否正确、惯量比设置、负载类型设置是否正确?

szllc

  • 精华:1帖
  • 求助:0帖
  • 帖子:40帖 | 220回
  • 年度积分:0
  • 历史总积分:351
  • 注册:2004年9月15日
发表于:2004-12-24 20:10:00
8楼
我是在电机不带负载的时候进行jog自运行的。 电机驱动器的参数pr12,pr12是电机的出场设置。 感谢各位的答复,圣诞快乐!

haiyun

  • 精华:0帖
  • 求助:0帖
  • 帖子:2帖 | 5回
  • 年度积分:0
  • 历史总积分:61
  • 注册:2004年12月29日
发表于:2004-12-29 09:01:00
9楼
我觉得 还是应看看速度输入信号的稳定性

szllc

  • 精华:1帖
  • 求助:0帖
  • 帖子:40帖 | 220回
  • 年度积分:0
  • 历史总积分:351
  • 注册:2004年9月15日
发表于:2004-12-29 15:11:00
10楼
我用示波器看了一下控制器的输出信号,看不出有什么干扰;可能是示波器精度不够。但是电机不带负载的时候进行jog自运行时,是不需要控制器的,是不是电机的问题? 电机在jog自运行时与编码器的线数有关吗?

沈阳老宋

  • 精华:0帖
  • 求助:0帖
  • 帖子:4帖 | 778回
  • 年度积分:4
  • 历史总积分:823
  • 注册:2004年9月30日
发表于:2004-12-29 21:37:00
11楼
伺服电机所有运动都与编码器有关,这点也是伺服与步进电机的区别之一,编码器反馈的信号是伺服电机计算的唯一根据,线数越多,意味伺服周期越短,在同样条件下,电机实际运行曲线与理论值越容易接近。电机JOG运行同样如此,只不过,JOG运行是用伺服电机内部设定的固有速度运行。伺服电机运行速度实际是一直在波动的,随着电机精度不同,波动范围也不同,速度波动必然引起震动,只不过震动程度不同。 一般讲,如果PID值调整合适,17位码盘电机轴的抖动凭手感,应该是感觉不到的。

云山雾海

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 25回
  • 年度积分:0
  • 历史总积分:35
  • 注册:2004年8月17日
发表于:2004-12-31 16:28:00
12楼
应该是驱动器参数没调整合适

szllc

  • 精华:1帖
  • 求助:0帖
  • 帖子:40帖 | 220回
  • 年度积分:0
  • 历史总积分:351
  • 注册:2004年9月15日
发表于:2005-01-03 15:39:00
13楼
驱动器参数我都是了几遍了。主要是pr10,pr11,pr12,还有pr20,pr22是吧? 但即使改变,也不能完全一点感觉不到,轻微的抖动还是有的。 会不会是力矩波动?

赖狗子

  • 精华:0帖
  • 求助:0帖
  • 帖子:4帖 | 58回
  • 年度积分:0
  • 历史总积分:94
  • 注册:2004年5月07日
发表于:2005-01-05 09:08:00
14楼
你用多大惯量多少功率的啊?

syney

  • 精华:0帖
  • 求助:0帖
  • 帖子:5帖 | 61回
  • 年度积分:0
  • 历史总积分:83
  • 注册:2004年7月08日
发表于:2005-01-05 23:29:00
15楼
电机在低速运行的时候是很容易引起震荡。 如果是自己做的控制器,升降速曲线做的不好也会引起振荡。

szllc

  • 精华:1帖
  • 求助:0帖
  • 帖子:40帖 | 220回
  • 年度积分:0
  • 历史总积分:351
  • 注册:2004年9月15日
发表于:2005-01-06 11:50:00
16楼
惯量比我设成65%。自动增益调处来是85%。(我从它们之间也改变过) 电机功率200w. 控制器买得是固高的 gt400-sv. 我的是指在静止的时候,摸再轴上有抖动。尤其是在电机跑到一个指定位置的时候,有时抖动很明显。 怀疑是电机不断hunting正确位置。 hunting是伺服电机的一个缺点,但是不知道有没有办法使控制器停止hunting,宁可有误差,不要hunting. 抖动虽然只有+/-1个脉冲,但是你想,假如给人做眼睛的激光治疗,就试治疗近视的那个,即使是+/-1个脉冲抖动,也会影响治疗效果啊。 是吧。 有的场合是对应用不造成影响,但从控制的角度来说,越精确越好,越稳定越好,对吧? 感谢各位。

taoyun7618

  • 精华:0帖
  • 求助:0帖
  • 帖子:2帖 | 17回
  • 年度积分:0
  • 历史总积分:210
  • 注册:2003年3月15日
发表于:2005-01-06 20:16:00
17楼
我用其他的伺服电极深圳步进代理的Ecostep系列,也遇上同样的问题,我也没有调好,我到是直接发给厂家、不过现在还没有给我答复呢!!!!

gongkongedit

  • 精华:1099帖
  • 求助:0帖
  • 帖子:14399帖 | 54471回
  • 年度积分:0
  • 历史总积分:579
  • 注册:2008年9月08日
发表于:2005-01-07 12:05:00
18楼
可能和上位控制也有关!当电机停止时,有可能由于指令位置为小数值而产生高频振动或者是累计增量误差在指令位置前后产生振动.我用PMAC卡时用修正指令可以解决类似的hunting.

kkbeer

  • 精华:0帖
  • 求助:0帖
  • 帖子:16帖 | 136回
  • 年度积分:0
  • 历史总积分:449
  • 注册:2003年2月16日
发表于:2005-01-07 12:41:00
19楼
你进行自运行时也有这种现象,所以可排除上位机等故障 还是惯量比设置不对。 如果是比较松的荡来荡去,那是惯量比太小,只有在带负载时才会发生空载时不会发生;如果是强烈振动,有时还在啸叫,是惯量比太大,空载时也会发生。从你的情况看,你设的惯量比太大。先把惯量比设为10%试试,再找一个平衡点就可以了。

szllc

  • 精华:1帖
  • 求助:0帖
  • 帖子:40帖 | 220回
  • 年度积分:0
  • 历史总积分:351
  • 注册:2004年9月15日
发表于:2005-01-07 13:05:00
20楼
应该这样说,在自运行的时候,是有抖动;用控制器控制的时候也有抖动;但无法判断这两者区别。二者产生机理不同。似乎有时用控制器的时候抖动大一些;。。。。。。。但是用自运行状态时增益设的大也会有类似现象。 确实可能是惯量比的问题。

相关主题

官方公众号

智造工程师
首页 上一页 1 2 下一页 尾页