西门子300plc的IO错误导致CPU停止 点击:3104 | 回复:13



sunjiekang123

    
  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 4回
  • 年度积分:0
  • 历史总积分:87
  • 注册:2019年6月28日
发表于:2019-11-17 23:09:02
楼主
求助帖30分-未结帖

有一台300plc没有子站,突然CPU和AO模块的SF灯亮,硬件组态在线监视发现AO模块故障,我换了一个新的AO模块后故障消除正常运行(但旧模块并没有坏,因为我换到其他地方可以正常使用)。运行了有三四个小时,又出现和刚才一样的故障,我断电重启了一下,故障消除试运行,没过几分钟一个24伏电源模块烧了, 于是我量了所有模块的每个端子的对地电阻,都没有接地。于是我换了新的24伏电源模块,上电后SF灯还亮,我看了下硬件组态和现场一样,在线监测发现从CPU后面所有模块都连接不上了(淡灰色的状态),我量了一下所有模块的供电电压都正常23.9伏,在线诊断了一下说是IO错误导致CPU停止,我断电后把CPU后面两个模块的U形背板换成新的,所有模块重新插拔,AO模块也重新换了。上电后CPU和模拟量模块的SF灯还亮,CPU运行不起来。 于是我从组态里把CPU后面所有的模块都删掉重新下载到CPU里,CPU还是起不来,诊断还是IO错误导致CPU停止。下载空程序进去也试了,还是一样的毛病。 不知道该怎么处理了,希望各位大神能指点一下。

wx_camera_1573870016789.jpg





林春胜

  • 精华:0帖
  • 求助:1帖
  • 帖子:2帖 | 71回
  • 年度积分:78
  • 历史总积分:2877
  • 注册:2018年12月16日
发表于:2019-11-18 06:36:18
1楼

模拟量输出超程吧,程序增加OB82/OB81了就不会停机了。具体是OB81还是OB82我记不清了。

robingsion

  • [版主]
  • 精华:20帖
  • 求助:71帖
  • 帖子:1936帖 | 3670回
  • 年度积分:936
  • 历史总积分:54944
  • 注册:2011年4月11日
发表于:2019-11-18 07:55:34
2楼

谢谢分享处理经验

回复内容:

对: 林春胜 模拟量输出超程吧,程序增加OB82/OB81了就不会停... 内容的回复!

-------------------------


郭远林

  • [版主]
  • 精华:3帖
  • 求助:8帖
  • 帖子:106帖 | 2106回
  • 年度积分:294
  • 历史总积分:43018
  • 注册:2011年10月21日
发表于:2019-11-19 15:21:51
3楼

查看一下帮助,估计就是CPU没有重新复位,你试试看能不能出现情况类似的

厉害了我

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 6回
  • 年度积分:0
  • 历史总积分:106
  • 注册:2016年12月05日
发表于:2019-11-20 10:31:31
4楼

谢谢分享     非常实用     研究一下

skyboyloveyou

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 8回
  • 年度积分:0
  • 历史总积分:9
  • 注册:2011年12月27日
发表于:2019-11-21 10:30:03
5楼

增加OB81~88中的块,另外还要看编程语言


云卷云舒12

  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 4回
  • 年度积分:0
  • 历史总积分:87
  • 注册:2019年6月28日
发表于:2019-11-22 15:38:47
6楼

回复内容:

对:郭远林 查看一下帮助,估计就是CPU没有重新复位,你试试看能不能出现情况类似的     内容的回复:

CPU断电重启了,也从STOP打到RUN,但是RUN的绿灯闪三秒钟就又灭了。 

云卷云舒12

  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 4回
  • 年度积分:0
  • 历史总积分:87
  • 注册:2019年6月28日
发表于:2019-11-22 16:11:48
7楼

回复内容:

对:林春胜 模拟量输出超程吧,程序增加OB82/OB81了就不会停机了。具体是OB81还是OB82我记不清了。     内容的回复:

可是你看最后一张图,我把硬件组态都删除了,就留了一个CPU,把所有程序都清空(保留OB1块,里面程序清空)下进去CPU起不来,模拟仿真一下CPU是绿灯可以起来,应该不存在超量程了把?   后来把每个模块的接线端子都重新紧了一下,原来的程序重新下进去就好了,这两天也没有出问题。    但还是不明白为什么空程序下到CPU里起不来的原因。

云卷云舒12

  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 4回
  • 年度积分:0
  • 历史总积分:87
  • 注册:2019年6月28日
发表于:2019-11-22 16:21:48
8楼

回复内容:

对:skyboyloveyou 增加OB81~88中的块,另外还要看编程语言     内容的回复:

程序应该是好的,我把空程序下进去也不好使,CPU起不来。后来把每个模块的所有接线端子重新紧固了一下就好了,但是不是只是由于这个问题导致的就不知道了。 

chjun

  • 精华:2帖
  • 求助:0帖
  • 帖子:74帖 | 243回
  • 年度积分:15
  • 历史总积分:605
  • 注册:2006年6月23日
发表于:2019-11-22 17:08:39
9楼


回复内容:

对: 云卷云舒12 回复内容:对:skyboyloveyou 增加OB81... 内容的回复!

-------------------------

后面的状况应该CP模块有问题了;

之前的状况先是AO报警,然后还烧了电源,有可能是AO输出有部分短路,或者端子排里面有问题,导致过电流电源故障;

过客一号

  • 精华:0帖
  • 求助:0帖
  • 帖子:1帖 | 2417回
  • 年度积分:0
  • 历史总积分:496
  • 注册:2017年6月09日
发表于:2019-11-24 16:18:31
10楼

感谢分享!

Smile-lyc

  • [管理员]
  • 精华:114帖
  • 求助:50帖
  • 帖子:2793帖 | 22283回
  • 年度积分:311
  • 历史总积分:144042
  • 注册:2006年8月04日
发表于:2020-01-04 14:33:27
11楼

赠人玫瑰,手留余香。

感谢你的求助和答疑,对于求助者请大家在求助帖发布一个月内给予结贴。

针对求助者自己解决问题后,及时把信息(问题解决措施和思路)反馈到自己帖子中,论坛给予20~50积分奖励。


带你装逼带你飞

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 2回
  • 年度积分:0
  • 历史总积分:58
  • 注册:2018年5月28日
发表于:2020-03-21 06:15:53
12楼

回复内容:

对:chjun 回复内容:对: 云卷云舒12 回复内容:对:skyboyloveyou 增加OB81... 内容的回复!-------------------------后面的状况应该CP模块有问题了;之前的状况先是AO报警,然后还烧了电源,有可能是AO输出有部分短路,或者端子排里面有问题,导致过电流电源故障;     内容的回复:

输出点位需带2A保险


热门招聘
相关主题

官方公众号

智造工程师