求助S7-200与PC通信问题 点击:12052 | 回复:18



dereck1314

    
  • 精华:0帖
  • 求助:1帖
  • 帖子:5帖 | 12回
  • 年度积分:0
  • 历史总积分:63
  • 注册:2013年5月07日
发表于:2013-06-04 15:09:24
楼主

我把plc接上电后,电缆连接pc机嘛,然后step7 MircoWIN sp9里面的通信老是连不上,


我试了两根电缆,在读取plc的时候一会显示通信超时,请检查端口号,网络地址,波特率和连接电缆,一会儿显示端口无法打开或正由另一个应用程序使用


求解决方法啊,下面一张出错图,还有一种情况没放上去,刚接触求高手详细指点啊!,谢谢!!!!

插入后设备管理显示:






qq176156511

  • 精华:0帖
  • 求助:2帖
  • 帖子:2帖 | 54回
  • 年度积分:0
  • 历史总积分:75
  • 注册:2008年12月21日
发表于:2013-06-04 15:15:40
1楼

USB/PPI  通讯线需要装驱动的    装好驱动 估计就好了

阿水--王者之师

  • 精华:44帖
  • 求助:508帖
  • 帖子:3327帖 | 22104回
  • 年度积分:2171
  • 历史总积分:92644
  • 注册:2007年3月22日
发表于:2013-06-04 15:34:33
2楼

1,检查你的线的驱动是完好安装

2,通讯端口在PG 启动时还有没有别的运行程序 ?

3,你的软件中设置的 PLC 与现场工作 PLC 型号与版本匹配不?

天陨

  • 精华:1帖
  • 求助:8帖
  • 帖子:14帖 | 50回
  • 年度积分:0
  • 历史总积分:188
  • 注册:2013年2月18日
发表于:2013-06-04 15:36:14
3楼

首先要安装相应的驱动,连接好数据线,在200软件中选择与plc模块对应的型号。然后在通信属性中 设置PG/PC接口 属性,选择正确的接口分配参数并进入属性对话框设置相应的参数,确认无误后,确定。要注意你的数据线是那种的,比如USB-PPI

dereck1314

  • 精华:0帖
  • 求助:1帖
  • 帖子:5帖 | 12回
  • 年度积分:0
  • 历史总积分:63
  • 注册:2013年5月07日
发表于:2013-06-04 15:49:47
4楼

回复内容:

对: 天陨 首先要安装相应的驱动,连接好数据线,在200软件中选择... 内容的回复!


谢谢你回答,看了大家的回答后,我怀疑我驱动没装,但是我usb插进去的时候在设备管理器里面硬件有反应,显示com1等什么的。 不知道这算不算装了驱动了?

狼牙精神

  • [版主]
  • 精华:6帖
  • 求助:6帖
  • 帖子:478帖 | 5375回
  • 年度积分:3385
  • 历史总积分:57634
  • 注册:2020年3月27日
发表于:2013-06-04 15:58:19
5楼

西门子原装的USB/PPI电缆不需要单独安装驱动,连接上USB/PPI电缆后PC会自动安装驱动。

出现这个问题首先要检查一下PC/PG接口是否设置正确,为什么图片里边没有PC/PG接口的设置呢?是不是没有设置呀?

PC/PG接口设置要根据你所用的PPI电缆来设置,PPI电缆有com口和USB口的,两种设置方法不一样。

dereck1314

  • 精华:0帖
  • 求助:1帖
  • 帖子:5帖 | 12回
  • 年度积分:0
  • 历史总积分:63
  • 注册:2013年5月07日
发表于:2013-06-04 15:58:47
6楼

我的plc 是s7-200 224cn,软件是step7 MircoWIN sp9,哪位哥哥有驱动能发我下不?万分感谢  邮箱mdereck2050@163.com

dereck1314

  • 精华:0帖
  • 求助:1帖
  • 帖子:5帖 | 12回
  • 年度积分:0
  • 历史总积分:63
  • 注册:2013年5月07日
发表于:2013-06-04 16:00:50
7楼

回复内容:

对: 狼牙精神 西门子原装的USB/PPI电缆不需要单独安装驱动,连接... 内容的回复!

嗯嗯,谢谢,不过原装的数据线丢了,用的是一般的那种淘宝货,您图上的我看到过了,选的是com1,难道要选usb?

狼牙精神

  • [版主]
  • 精华:6帖
  • 求助:6帖
  • 帖子:478帖 | 5375回
  • 年度积分:3385
  • 历史总积分:57634
  • 注册:2020年3月27日
发表于:2013-06-04 17:20:35
8楼

你如果用的是USB/PPI电缆选择com1是不对的,应该选USB。

一枚铜钱

  • 精华:1帖
  • 求助:0帖
  • 帖子:8帖 | 428回
  • 年度积分:35
  • 历史总积分:840
  • 注册:2005年7月17日
发表于:2013-06-05 09:41:08
9楼

最好的解决办法就是:把PLC的开关打到STOP位置,然后给PLC断电再上电,再连接

ANDYLIU008

  • 精华:1帖
  • 求助:2帖
  • 帖子:32帖 | 476回
  • 年度积分:11
  • 历史总积分:1874
  • 注册:2009年12月12日
发表于:2013-06-05 09:50:35
10楼

试下把PC/PG设置里面的波特率更改一下

dereck1314

  • 精华:0帖
  • 求助:1帖
  • 帖子:5帖 | 12回
  • 年度积分:0
  • 历史总积分:63
  • 注册:2013年5月07日
发表于:2013-06-06 10:29:01
11楼

回复内容:

对: 狼牙精神 你如果用的是USB/PPI电缆选择com1是不对的,应... 内容的回复!


嗯,谢谢哈,我试试。

yangdingyong

  • 精华:0帖
  • 求助:2帖
  • 帖子:7帖 | 108回
  • 年度积分:19
  • 历史总积分:242
  • 注册:2009年9月09日
发表于:2013-06-06 13:39:12
12楼

我遇见过一次  是编程软件的问题   重新装了下编程软件就好了

dereck1314

  • 精华:0帖
  • 求助:1帖
  • 帖子:5帖 | 12回
  • 年度积分:0
  • 历史总积分:63
  • 注册:2013年5月07日
发表于:2013-06-06 20:21:20
13楼

谢谢大家,万分感谢,我搞定了

蔡一欣

  • 精华:0帖
  • 求助:15帖
  • 帖子:16帖 | 22回
  • 年度积分:0
  • 历史总积分:89
  • 注册:2016年3月28日
发表于:2016-04-01 18:11:56
14楼
求问怎么搞定的哦,我也遇到了一样的问题~

金前龙

  • 精华:0帖
  • 求助:0帖
  • 帖子:1帖 | 1回
  • 年度积分:3
  • 历史总积分:14
  • 注册:2016年12月01日
发表于:2016-12-01 15:06:26
15楼


回复内容:

对: dereck1314 回复内容:对: 狼牙精神  你如果用的是USB/PPI... 内容的回复!


Antiz

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 10回
  • 年度积分:0
  • 历史总积分:48
  • 注册:2017年1月06日
发表于:2017-04-14 20:03:19
16楼


回复内容:

对: dereck1314 谢谢大家,万分感谢,我搞定了 内容的回复!

我今天也遇到了同样的问题 你是怎么解决的 谢谢 急用

童敏

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 7回
  • 年度积分:0
  • 历史总积分:31
  • 注册:2015年6月08日
发表于:2017-12-13 16:50:47
17楼

我今天也连不上,看一下大家的办法

ntplc2017

  • 精华:0帖
  • 求助:0帖
  • 帖子:38帖 | 375回
  • 年度积分:0
  • 历史总积分:685
  • 注册:2018年5月11日
发表于:2018-08-10 10:44:32
18楼

情况复杂,不好描述:  a)首先使用的编程线的种类需要确认:通常有USB直接驱动的和USB转COM口驱动的方式, 图上来看是走COM口的COM2,  但实际是否走COM需要先看线的驱动,并在电脑的设备管理器这里识别到COM口的号码;  b)PLC端需要拨到STOP状态,如果PLC里面有写入了MODBUS通信或者自由口通信,在RUN状态下是无法通信的   c)如果PLC运行在187.5K的波特率下,那么同USB转COM口的线是无法进行通信的,只能使用西门子原装的USB直驱线进行通信   d)PLC编程软件如果没有安装完善,是无法通信的    e)PLC编程软件端的设置如果不正确无法正确通信, 通常设置中注意选择PC-PPI 协议,本地地址选择0,高级PPI和多主站不要选中;  f)以上所有问题排除后,再考虑是否是通信线或PLC故障。



相关主题

官方公众号

智造工程师