三菱PLC只有输入信号没有输出信号,求教 点击:0 | 回复:10



shmily050101

    
  • 精华:0帖
  • 求助:0帖
  • 帖子:1帖 | 3回
  • 年度积分:0
  • 历史总积分:3
  • 注册:2008年3月18日
发表于:2009-07-23 23:29:40
楼主

我们的一台设备,用的是三菱FX(2N)的PLC,现在问题是只有输入信号,一个输出信号也没有,只有按急停的时候才有一个信号,闷,现在PLC*E的指示灯再闪,看帮助说是“程序求和错误”这个该怎么解决啊?求XDJM们指教!不胜感激!




dongdong20022006

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 6回
  • 年度积分:0
  • 历史总积分:2
  • 注册:2009年7月24日
发表于:2009-07-24 00:24:28
1楼

现场工作经验告诉我们,程序卡住的情况是非常少见的,设备控制出现问题,99%的情况是因为现场问题,跟程序没什么关系

没有输出信号会不会是现场输出信号接线端子松动或者通讯模块连接松动,要不重新把PLC上电试试

zhousy008

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 2回
  • 年度积分:0
  • 历史总积分:1
  • 注册:2009年7月24日
发表于:2009-07-24 07:26:47
2楼

同意楼上的,要不还有种可能负载把点烧坏了

沉默无罪

  • 精华:0帖
  • 求助:0帖
  • 帖子:12帖 | 62回
  • 年度积分:0
  • 历史总积分:295
  • 注册:2007年12月26日
发表于:2009-07-24 07:36:25
3楼
基本都是接线问题 或者程序问题 用电脑在线看一下就知道了

qinyingtai

  • 精华:0帖
  • 求助:0帖
  • 帖子:2帖 | 61回
  • 年度积分:0
  • 历史总积分:135
  • 注册:2009年4月11日
发表于:2009-07-24 08:13:44
4楼
更有一些人,连RUN开关都没查打没打上去,就说PLC 出问题了,以前碰过这样的人,还有支持楼上几位的~

shmily050101

  • 精华:0帖
  • 求助:0帖
  • 帖子:1帖 | 3回
  • 年度积分:0
  • 历史总积分:3
  • 注册:2008年3月18日
发表于:2009-07-24 18:59:23
5楼

这里先谢过大家的帮助,这个问题暂时解决啦!此前接线端子全部都拆下来从新接的!绝不是这个情况!

现办法是这样的:先传了个空程序进去,在把原来的程序再一次传进去关电从启就没问题啦!但是我想可能这并不是问题的真正所在!

查资料说有以下几种情况:1,PLC内部进去导电物质,产生噪音;

2,监视器设置的超出范围;

3,时钟运行时间超长;

4,程序的长度超过存储长度

现在正在继续查找中... ...

dongdong20022006

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 6回
  • 年度积分:0
  • 历史总积分:2
  • 注册:2009年7月24日
发表于:2009-07-24 23:35:08
6楼

不知道你用的是那个型号,三菱FX系列里面8002这个点好象是管所有输出的,如果这个点接通,所有输出都被屏蔽了。

袁泉

  • 精华:2帖
  • 求助:14帖
  • 帖子:242帖 | 1734回
  • 年度积分:119
  • 历史总积分:3101
  • 注册:2005年4月26日
发表于:2009-07-26 11:08:15
7楼
输出指示灯亮吗????????

lizhibin520

  • 精华:2帖
  • 求助:0帖
  • 帖子:8帖 | 47回
  • 年度积分:0
  • 历史总积分:71
  • 注册:2009年7月22日
发表于:2009-07-26 11:29:02
8楼

很有可能是电池没有电了,导致程序丢失。

你用软件看看程序还能读出来吗?

 如果需要重新写程序,可以联系我。

13621827873  李先生

zhjb

  • 精华:0帖
  • 求助:0帖
  • 帖子:1帖 | 52回
  • 年度积分:0
  • 历史总积分:126
  • 注册:2003年3月11日
发表于:2009-07-27 11:09:59
9楼
同意4楼意见..........

楚留香

  • 精华:0帖
  • 求助:0帖
  • 帖子:49帖 | 976回
  • 年度积分:0
  • 历史总积分:1552
  • 注册:2003年3月21日
发表于:2009-07-27 17:05:56
10楼
支持4楼的说法,有人会犯低级错误

乖乖小笨熊

  • 精华:2帖
  • 求助:0帖
  • 帖子:1159帖 | 10637回
  • 年度积分:5
  • 历史总积分:50704
  • 注册:2006年8月05日
发表于:2021-01-05 13:25:30
11楼

这个很正常啊!

例如用了CC-LINK,此时cc-link总线发生溢出就可能导致当机的,起码我遇到过

重新传输程序就好了,这个一般发生在在线调试发送错误命令时。

其实西门子1215C也遇到PN总线导致的当机——都是程序传输时发生的


相关主题

官方公众号

智造工程师