部件名称乱了 点击:214 | 回复:10



心有意而燃

    
  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 1回
  • 年度积分:87
  • 历史总积分:87
  • 注册:2022年11月05日
发表于:2022-11-21 17:03:07
楼主
求助帖30分-已结帖

大神们我建好部件后可以正常使用,但是复制做好的部件到新的页面里去,原来的部件再拉出来用,预览的时候还是正常的,但是点了确定后,部件的某些端子名称就变了,这个怎么改呀?

没有点确定时如下图

企业微信截图_16690209912500.png

点了确定后,如下图

企业微信截图_16690210234839.png



冥王星星

  • [版主]
  • 精华:0帖
  • 求助:1帖
  • 帖子:8帖 | 37回
  • 年度积分:1601
  • 历史总积分:1659
  • 注册:2020年1月08日
发表于:2022-11-21 18:19:56
1楼

复制的选择不修改名称看看

冥王星星

  • [版主]
  • 精华:0帖
  • 求助:1帖
  • 帖子:8帖 | 38回
  • 年度积分:1602
  • 历史总积分:1660
  • 注册:2020年1月08日
发表于:2022-11-21 18:24:29
2楼

截图01.png如图选择不更改看看

心有意而燃

  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 1回
  • 年度积分:89
  • 历史总积分:89
  • 注册:2022年11月05日
发表于:2022-11-22 09:26:46
3楼

"冥王星星" 的回复,发表在2楼
        对内容: 【如图选择不更改看看】进行回复:

        -----------------------------------------------------------------

我复制后选择的是不更改的这个选项,这个是在宏项目里操作的,自动生成宏后,去原理图里面调用部件,部件的端子名称和宏项目里的就不一样了


冥王星星

  • [版主]
  • 精华:0帖
  • 求助:1帖
  • 帖子:8帖 | 39回
  • 年度积分:1608
  • 历史总积分:1666
  • 注册:2020年1月08日
发表于:2022-11-23 09:27:27
4楼

截图03.png看看部件库中的零部件中的宏图形和你修改宏图形相同不了。

心有意而燃

  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 2回
  • 年度积分:90
  • 历史总积分:90
  • 注册:2022年11月05日
发表于:2022-11-23 10:46:59
5楼

"冥王星星" 的回复,发表在4楼
        对内容: 【看看部件库中的零部件中的宏图形和你修改宏图形相同不了。】进行回复:

        -----------------------------------------------------------------

我没有用图形宏,我用的那个宏边框,把做好的部件框选后自动生成的

image.png


冥王星星

  • [版主]
  • 精华:0帖
  • 求助:1帖
  • 帖子:8帖 | 40回
  • 年度积分:1609
  • 历史总积分:1667
  • 注册:2020年1月08日
发表于:2022-11-23 20:28:52
6楼

我这里创建宏后再插入,都是选择不更改的,需要哪些在修改使用的,你这个看编号是自动生成的PLC地址编号。插入PLC模块时选择编号修改就会出现系统添加的灰色字体的PLC地址和你发的图片上的字体相同。

16938387

  • 精华:0帖
  • 求助:1帖
  • 帖子:2帖 | 57回
  • 年度积分:137
  • 历史总积分:137
  • 注册:2014年6月11日
发表于:2022-11-23 21:29:28
7楼

学习了

心有意而燃

  • 精华:0帖
  • 求助:2帖
  • 帖子:2帖 | 3回
  • 年度积分:45
  • 历史总积分:45
  • 注册:2022年11月05日
发表于:2022-11-24 09:49:46
8楼

"冥王星星" 的回复,发表在6楼
        对内容: 【我这里创建宏后再插入,都是选择不更改的,需要哪些在修改使用的,你这个看编号是自动生成的PLC地址编号。插入PLC模块时选择编号修改就会出现系统添加的灰色字体的PLC地址和你发的图片上的字体相同。...】进行回复:

        -----------------------------------------------------------------

我选择的是不更改,已经重试甚至重新做了都会这样,只有新建了那个mdb文件,然后把做好的edz文件导出去,再导进来,再去原理图项目里调用才不会出现这个问题。

临时的解决方法是找到了,但是问题原因还没找到,还是感谢您的回复解答。

image.png


阿水--王者之师

  • 精华:44帖
  • 求助:509帖
  • 帖子:3337帖 | 22253回
  • 年度积分:208
  • 历史总积分:98192
  • 注册:2007年3月22日
发表于:2022-11-24 14:10:44
9楼

   这个是什么软件,没有用过

忘记了

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 3回
  • 年度积分:98
  • 历史总积分:98
  • 注册:2022年10月26日
发表于:2022-11-25 13:50:40
10楼

"阿水--王者之师" 的回复,发表在9楼
        对内容: 【这个是什么软件,没有用过】进行回复:

        -----------------------------------------------------------------


eplan


热门招聘
相关主题

官方公众号

智造工程师