S7-300与6SE70 DP通信,PLC接收到数据不稳定 点击:0 | 回复:13



addengao

    
  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 8回
  • 年度积分:0
  • 历史总积分:75
  • 注册:2010年5月25日
发表于:2011-11-23 15:51:55
楼主
求助帖10分-已结帖
小弟有个项目,用S7-300读6SE70变频器电流值,正常运行时读取的数据经常出现0的情况,各位大侠给支个招看有什么解决办法,感谢!!!



Gxuecheng

  • 精华:0帖
  • 求助:0帖
  • 帖子:3帖 | 20回
  • 年度积分:0
  • 历史总积分:133
  • 注册:2008年7月01日
发表于:2011-11-23 21:11:37
1楼
现象描述不详细,最好能再具体点

kskstiy

  • 精华:0帖
  • 求助:1帖
  • 帖子:4帖 | 379回
  • 年度积分:0
  • 历史总积分:2649
  • 注册:2010年8月30日
发表于:2011-11-24 08:54:00
2楼

不知道你的DP波特率是多少,不行的话降低波特率看下效果

另外无非就是检查DP通讯线的屏蔽层接线什么的

miy_gongkong

  • 精华:0帖
  • 求助:3帖
  • 帖子:32帖 | 3048回
  • 年度积分:521
  • 历史总积分:12307
  • 注册:2008年9月18日
发表于:2011-11-24 09:08:54
3楼
引用kskstiy 的回复内容:

不知道你的DP波特率是多少,不行的话降低波特率看下效果

另外无非就是检查DP通讯线的屏蔽层接线什么的





zhangyungang

  • 精华:0帖
  • 求助:6帖
  • 帖子:23帖 | 126回
  • 年度积分:1
  • 历史总积分:533
  • 注册:2011年2月22日
发表于:2011-11-24 10:12:29
4楼
变频器接地如何啊 检查变频器的接地把

QHDTHL

  • 精华:1帖
  • 求助:0帖
  • 帖子:42帖 | 1366回
  • 年度积分:0
  • 历史总积分:14740
  • 注册:2006年12月21日
发表于:2011-11-24 16:08:00
5楼
出现0的情况,应该是数据丢失,先前正常数据交换,说明软件设置没有问题,现在出现了数据丢失,应该是硬件问题,查一查通讯线是否有损坏,通讯接口有无问题,如果查不出来那就得检测PLC和变频器硬件了。

niki

  • [版主]
  • 精华:7帖
  • 求助:2帖
  • 帖子:675帖 | 1135回
  • 年度积分:380
  • 历史总积分:7191
  • 注册:2009年2月24日
发表于:2011-11-25 13:39:40
6楼

大连德嘉国际的ETH-MPI(DP)转换器,它一端连接s7-300/400PLC的MPI编程口,另一端是RJ45以太网接口(是西门子 profinet (tcp/ip)协议接口),上位机WINCC或STEP7 通过普通以太网卡与之相连,使用西门子本身的 TCP/IP协议,它的主要应用是为WINCC提供可靠便捷低价的接口设备.

详见公司网站www.dl-winbest.cn

千山独步

  • 精华:0帖
  • 求助:0帖
  • 帖子:165帖 | 3097回
  • 年度积分:244
  • 历史总积分:21070
  • 注册:2007年2月02日
发表于:2011-11-26 04:58:09
7楼
6se70变频器的电流连接量是设置的K022吗? 所谓的电流显示为零,是在wincc画面上吗,还是用step7 监控的?

千山独步

  • 精华:0帖
  • 求助:0帖
  • 帖子:165帖 | 3097回
  • 年度积分:244
  • 历史总积分:21070
  • 注册:2007年2月02日
发表于:2011-11-26 05:01:30
8楼
检查一下PLC读取变频器的状态字的参数设置,其它的通迅数据显示或控制正常吗

ye_w

  • 精华:25帖
  • 求助:1帖
  • 帖子:106帖 | 5215回
  • 年度积分:12
  • 历史总积分:46721
  • 注册:2002年4月17日
发表于:2011-11-26 06:41:20
9楼
当发生数据为零时,CPU上的LED灯的状态是?

阿水

  • 精华:44帖
  • 求助:508帖
  • 帖子:3327帖 | 22104回
  • 年度积分:2171
  • 历史总积分:92644
  • 注册:2007年3月22日
发表于:2011-11-26 07:39:06
10楼

只是有时数据为"0"是在什么软件测试出来的?"

建议用监控软件检查看看, 是不是干扰??所有接地都做好了吗"

addengao

  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 8回
  • 年度积分:0
  • 历史总积分:75
  • 注册:2010年5月25日
发表于:2011-12-01 20:46:13
11楼
回复内容:
对:千山独步关于检查一下PLC读取变频器的状态字的参数设置,其它的通迅数据显示或控制正常吗 内容的回复:

谢谢您的分析,问题已经解决,读K022的值,程序用错了一个数据类型转换块,BCD码转换成DI时,偶尔就用出现0的情况

addengao

  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 8回
  • 年度积分:0
  • 历史总积分:75
  • 注册:2010年5月25日
发表于:2011-12-01 20:47:52
12楼
回复内容:
对:阿水关于只是有时数据为"0"是在什么软件测试出来的?"建议用监控软件检查看看, 是不是干扰??所有接地都做好了吗"内容的回复:

接地没有问题,不过DP线有点短,小于1M了,现在问题已经解决,谢谢

季盟

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 36回
  • 年度积分:0
  • 历史总积分:22
  • 注册:2014年10月22日
发表于:2016-05-31 08:16:31
13楼

不知道你的DP波特率是多少,不行的话降低波特率看下效果

另外无非就是检查DP通讯线的屏蔽层接线什么的



相关主题

官方公众号

智造工程师