PLC模拟量输入有波动怎么办? 点击:0 | 回复:38



约等于

    
  • 精华:1帖
  • 求助:0帖
  • 帖子:3帖 | 9回
  • 年度积分:0
  • 历史总积分:0
  • 注册:1900年1月01日
发表于:2004-02-06 20:23:00
楼主
PLC电压值0-10V模拟量输入,在输入信号没有变化的情况下,通过上位机看到部分输入的数值有大约1/300的波动,但是有的输入数值就没有变化而且比较稳定,把稳定和不稳定输入在PLC上的端子更换后无效。在这种情况下怎么办?请大虾指点!



愚公公

  • 精华:1帖
  • 求助:0帖
  • 帖子:8帖 | 88回
  • 年度积分:0
  • 历史总积分:163
  • 注册:2003年7月10日
发表于:2003-07-12 14:55:00
1楼
外加一个阻容滤波电路 输入------||-----------------PLC输入 (电容) | _ | | (电阻) - | 地-------------------------------------

仪表新兵

  • 精华:1帖
  • 求助:0帖
  • 帖子:38帖 | 387回
  • 年度积分:0
  • 历史总积分:508
  • 注册:2003年4月14日
发表于:2003-07-12 20:21:00
2楼
是来自于干扰,使用屏蔽线,接地要作好,不要与动力线平行。

microtomato

  • 精华:1帖
  • 求助:0帖
  • 帖子:100帖 | 1476回
  • 年度积分:1
  • 历史总积分:2059
  • 注册:2001年11月02日
发表于:2003-07-13 19:24:00
3楼
在PLC程序中采用滤波算法

gongkongedit

  • 精华:1099帖
  • 求助:0帖
  • 帖子:14399帖 | 54471回
  • 年度积分:0
  • 历史总积分:579
  • 注册:2008年9月08日
发表于:2003-07-17 13:25:00
4楼
我刚作完一个工程,也发现了类似的现象。其主要原因来自外部的干扰,请检查一下线路,是否使用了屏蔽线,是否接地符合要求。周围有无强电的干扰。

丁香花开

  • 精华:0帖
  • 求助:0帖
  • 帖子:4帖 | 27回
  • 年度积分:0
  • 历史总积分:42
  • 注册:2002年7月01日
发表于:2003-07-17 16:16:00
5楼
我的4~20ma信号模拟量输入,有时有10%左右的偏差,有时又正常,是否也是干扰问题?

仪表新兵

  • 精华:1帖
  • 求助:0帖
  • 帖子:38帖 | 387回
  • 年度积分:0
  • 历史总积分:508
  • 注册:2003年4月14日
发表于:2003-07-17 22:18:00
6楼
如果可以排除PLC输入模块的原因,应当是干扰的问题。你可以接个标准信号源测测,也可以接个5#电池,他的输入相当于1.5v/250欧。你看看稳定不(当然得在模块的接线端子上接)。

丁香花开

  • 精华:0帖
  • 求助:0帖
  • 帖子:4帖 | 27回
  • 年度积分:0
  • 历史总积分:42
  • 注册:2002年7月01日
发表于:2003-07-28 10:41:00
7楼
plc模拟输入模块的抗干扰能力比DDZ3型仪表差吗?我在实际应用中曾经采用仪表和plc直接串联来同时显示现场的4~20ma的参数,结果发现plc的显示有时出现偏差,而仪表不会。

达欣

  • 精华:0帖
  • 求助:0帖
  • 帖子:1帖 | 13回
  • 年度积分:0
  • 历史总积分:58
  • 注册:2003年7月09日
发表于:2003-07-30 15:21:00
8楼
楼上说的对,100%的干扰引起的。   检查线路走向是否太靠近动力线且平行,再查屏蔽是否良好。

lenny

  • 精华:1帖
  • 求助:0帖
  • 帖子:2帖 | 45回
  • 年度积分:0
  • 历史总积分:110
  • 注册:2003年7月29日
发表于:2003-07-31 10:17:00
9楼
是不是用的SIEMENS的PLC?我做过许多试验,如果是SIEMENS的PLC不管是200还是300在实验室做A/D转换都有数百到上千的波动,实验室的条件算好了吧,就算按手册上完全做好各种屏蔽仍有此现象,我也想解决呢?可是用其它品牌的好象波动很小,可做到1或2的变化都可以.不能多说了,否则有人又说有贬SIEMENS之意了.

丁香花开

  • 精华:0帖
  • 求助:0帖
  • 帖子:4帖 | 27回
  • 年度积分:0
  • 历史总积分:42
  • 注册:2002年7月01日
发表于:2003-07-31 13:06:00
10楼
是omron的c200he系列ad003.

gongkongedit

  • 精华:1099帖
  • 求助:0帖
  • 帖子:14399帖 | 54471回
  • 年度积分:0
  • 历史总积分:579
  • 注册:2008年9月08日
发表于:2003-07-31 13:28:00
11楼
你可以把模块一的供电负端和信号的负端封在一起,再把信号的屏蔽接好地就可以了!

星际

  • 精华:0帖
  • 求助:0帖
  • 帖子:6帖 | 7回
  • 年度积分:0
  • 历史总积分:76
  • 注册:2003年6月11日
发表于:2004-01-09 15:39:00
12楼
同意楼上的说法

yang1858

  • 精华:1帖
  • 求助:0帖
  • 帖子:15帖 | 7回
  • 年度积分:0
  • 历史总积分:55
  • 注册:2002年3月12日
发表于:2004-01-09 15:53:00
13楼
同意楼上说法,尽量远离干扰源,使用屏蔽电缆,注意接地,实在不行,就在程序中采用滤波算法。

gongkongedit

  • 精华:1099帖
  • 求助:0帖
  • 帖子:14399帖 | 54471回
  • 年度积分:0
  • 历史总积分:579
  • 注册:2008年9月08日
发表于:2004-01-10 13:23:00
14楼
轻生经历,艰难解决---模量输入(两线制液位变送器)24V电源接地!我采用外供24V电源。 有时外供24V电源和PLC24V电源产生竞争,也是如此! 轻生经历!!!!!

gongkongedit

  • 精华:1099帖
  • 求助:0帖
  • 帖子:14399帖 | 54471回
  • 年度积分:0
  • 历史总积分:579
  • 注册:2008年9月08日
发表于:2004-01-10 13:30:00
15楼
不是由于动力电源感应而产生的干扰。请采用等电位接地。

网球

  • 精华:0帖
  • 求助:0帖
  • 帖子:31帖 | 403回
  • 年度积分:0
  • 历史总积分:522
  • 注册:2002年8月06日
发表于:2004-01-11 20:23:00
16楼
如果你采集允许较长间断采集你可以选择软件滤波,就是用平均算法。如果不允许那么建议你更换传感器的变送器,一般滤波都是应该他来完成的。不过模拟量选择电压本来就容易被干扰的。如果是电流,效果就好的多。

gongkongedit

  • 精华:1099帖
  • 求助:0帖
  • 帖子:14399帖 | 54471回
  • 年度积分:0
  • 历史总积分:579
  • 注册:2008年9月08日
发表于:2004-02-05 20:20:00
17楼
我有一个很好方法:用屏蔽双绞电缆线,如果还不行就用0--10v改成4---20ma输入肯定行的。不明白的:qq:94459327

远离自宫

  • 精华:0帖
  • 求助:0帖
  • 帖子:2帖 | 6回
  • 年度积分:0
  • 历史总积分:25
  • 注册:2003年12月11日
发表于:2004-02-06 14:21:00
18楼
对于接地的解决好像很难,而且现在用的普通的双绞线屏蔽效果应该还算不错的吧,只是感觉接地电阻偏大(1.2欧),这样会导致很大的干扰么?而且我遇到的不仅仅是模拟量受干扰的问题,对于开关量也有类似的问题。请高手指点,谢谢!

周公

  • 精华:10帖
  • 求助:0帖
  • 帖子:128帖 | 5549回
  • 年度积分:3
  • 历史总积分:6504
  • 注册:2002年11月26日
发表于:2004-02-06 16:36:00
19楼
参见‘传感器与仪表’版块《关于抗干扰问题的一些考虑》本人原创

chbchb

  • 精华:2帖
  • 求助:0帖
  • 帖子:6帖 | 103回
  • 年度积分:0
  • 历史总积分:237
  • 注册:2002年4月07日
发表于:2004-02-06 20:23:00
20楼
告诉你一个既有效又简单的方法,在plc模块前面加一只隔离器,将输入信号隔离后进入plc模块,保证解决问题,本人已经遇到好几次类似情况(西门子plc尤其严重),均已圆满解决!!我公司即可提供类似的隔离器,如有需要请来电025-84459479 陈工

相关主题

官方公众号

智造工程师
首页 上一页 1 2 下一页 尾页