昆仑通态和西门子smart的MODBUSTCP怎么设置 点击:260 | 回复:10



林斌123456

    
  • 精华:0帖
  • 求助:23帖
  • 帖子:25帖 | 23回
  • 年度积分:141
  • 历史总积分:287
  • 注册:2012年10月13日
发表于:2021-01-23 09:46:19
楼主
求助帖60分-已结帖

我有一个外购设备的昆仑通态屏要和公司的电箱中西门子w smart200走MODBUS TCP通讯。

从没有这样弄过,所以我用一块昆仑屏做实验一下,结果没有成功。 请问大家我错在哪里。


所用硬件:昆仑屏(192.168.2.20),交换机,smart200 V2.5(192.168.2.1).

昆仑屏做客户端,西门子做服务器。做了一个上午没有成功,是什么原因。


4.jpg


1分不嫌少!



AI雪

  • 精华:0帖
  • 求助:0帖
  • 帖子:1帖 | 148回
  • 年度积分:2
  • 历史总积分:879
  • 注册:2016年8月07日
发表于:2021-01-23 11:55:35
1楼

第二张图的设备地址 我记得默认好像是255吧 你得查查200smart那边地址是多少

关育谋

  • [版主]
  • 精华:4帖
  • 求助:21帖
  • 帖子:382帖 | 4998回
  • 年度积分:454
  • 历史总积分:37635
  • 注册:2004年5月28日
发表于:2021-01-23 17:03:32
2楼

先用第三方调试软件测试一下西门子S7-200 Smart系列PLC之Modbus TCP服务器的程序,看看是否成功。

关育谋

  • [版主]
  • 精华:4帖
  • 求助:21帖
  • 帖子:382帖 | 4998回
  • 年度积分:454
  • 历史总积分:37635
  • 注册:2004年5月28日
发表于:2021-01-23 17:05:22
3楼

还有,第一张图中的本地端口号和远程端口号你是不是搞反了,本地端口号指的是触摸屏的端口号、远程端口号指的是PLC的端口号,你PLC程序中的端口号设定为502了,那么触摸屏中远程设备端口号也要为502.

아득하다.

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 17回
  • 年度积分:2
  • 历史总积分:127
  • 注册:2015年11月24日
发表于:2021-01-24 18:04:32
4楼

直接用smart200的驱动不就行了 在PLC选项里就有

아득하다.

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 17回
  • 年度积分:2
  • 历史总积分:127
  • 注册:2015年11月24日
发表于:2021-01-24 18:10:31
5楼

捕获.PNG

Mars-chan

  • [版主]
  • 精华:0帖
  • 求助:4帖
  • 帖子:23帖 | 341回
  • 年度积分:54
  • 历史总积分:1811
  • 注册:2019年4月01日
发表于:2021-01-24 21:36:00
6楼

你本地和远程的端口号,感觉弄反了 。还有可以试过其他的波特率

关育谋

  • [版主]
  • 精华:3帖
  • 求助:21帖
  • 帖子:382帖 | 4999回
  • 年度积分:159
  • 历史总积分:37740
  • 注册:2004年5月28日
发表于:2021-01-26 14:38:04
7楼

引用 "Mars-chan" 的回复,发表在6楼
        内容: 你本地和远程的端口号,感觉弄反了 。还有可以试过其他的波特率

以太网通信和波特率啥关系?

长夜月风

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 3回
  • 年度积分:32
  • 历史总积分:32
  • 注册:2021年1月27日
发表于:2021-01-27 11:50:02
8楼

为什么不直接用西门子的驱动通讯?触摸屏里面可以直接选的,还有你第一张图里面的端口号跟你PLC里面的端口号是不是应该搞反了,你这种方法还的注意一下地址映射的问题。

Houcrstl 淇

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 0回
  • 年度积分:40
  • 历史总积分:40
  • 注册:2020年12月03日
发表于:2021-01-27 13:19:39
9楼

看着不像啊

落叶归根87

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 284回
  • 年度积分:0
  • 历史总积分:143
  • 注册:2013年8月05日
发表于:2021-01-30 16:11:55
10楼

确认端口号错误,可以用ModbusTcp网络助手调试,好判断哪边设置有问题


相关主题

官方公众号

智造工程师