首页 上一页 1 2 下一页 尾页

三菱FX2N-4AD-PT不变送温度步科触摸屏不显示温度值 点击:1543 | 回复:25



海娃娃

    
  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 30回
  • 年度积分:0
  • 历史总积分:162
  • 注册:2017年3月04日
发表于:2019-12-16 21:43:22
楼主
求助帖30分-未结帖

我们的冷库控制系统用的是三菱FX 3U PLC   系统有  有四个特殊模块   两个FX2N-4AD  和两个FX2N-4 AD-PT模块

现在出现的情况是有一块FX2N-4AD-PT模块出现了在触摸屏上不显示温度  模块上灯也不亮   之前我把其他控制系统的FX2N-4AD- PT 模块进行了交换 结果就不显示了  各位大佬  跪求怎么让它重新开始变送温度  在触摸屏上显示?





海娃娃

  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 30回
  • 年度积分:0
  • 历史总积分:162
  • 注册:2017年3月04日
发表于:2019-12-16 21:45:27
1楼

跪求各位大佬怎么才能让它重新显示温度?

xiexie1999

  • [版主]
  • 精华:1帖
  • 求助:12帖
  • 帖子:717帖 | 3885回
  • 年度积分:23
  • 历史总积分:160147
  • 注册:2013年4月29日
发表于:2019-12-17 08:01:14
2楼

模块上灯都不良?可以先检查模块上电源接入有没有问题   接入正常有可能就是模块问题了

xiexie1999

  • [版主]
  • 精华:1帖
  • 求助:12帖
  • 帖子:717帖 | 3885回
  • 年度积分:23
  • 历史总积分:160147
  • 注册:2013年4月29日
发表于:2019-12-17 08:02:58
3楼

还有主PLC是不是报警了?可以用软件看看是什么报警

海娃娃

  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 30回
  • 年度积分:0
  • 历史总积分:162
  • 注册:2017年3月04日
发表于:2019-12-17 08:16:23
4楼


回复内容:

对: xiexie1999 模块上灯都不良?可以先检查模块上电源接入有没有问题  ... 内容的回复!

-------------------------刚开始这个模块的灯都是亮的  温度显示也正常   就是出现报警4AD-PT地址错误   我就怀疑是模块通讯线有问题   我找了相同4AD- PT模块换上也不显示    换回去原来的模块也不显示了   灯也模块最下边的灯也不亮了


海娃娃

  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 30回
  • 年度积分:0
  • 历史总积分:162
  • 注册:2017年3月04日
发表于:2019-12-17 08:21:20
5楼


回复内容:

对: xiexie1999 还有主PLC是不是报警了?可以用软件看看是什么报警 内容的回复!

-------------------------正常情况这个模块如果出现错误   比如接线错误  电源错误   地址错误   识别码错误这些错误   然后如果我换回原来正确模块会自己恢复正常吗?


xiexie1999

  • [版主]
  • 精华:1帖
  • 求助:12帖
  • 帖子:717帖 | 3885回
  • 年度积分:23
  • 历史总积分:160147
  • 注册:2013年4月29日
发表于:2019-12-17 08:35:59
6楼


回复内容:

对: 海娃娃 回复内容:对: xiexie1999  还有主PLC是... 内容的回复!

-------------------------

有没有断电重新写入试试

请叫我王老湿

  • [版主]
  • 精华:0帖
  • 求助:0帖
  • 帖子:622帖 | 8531回
  • 年度积分:91
  • 历史总积分:332562
  • 注册:2011年4月25日
发表于:2019-12-17 08:47:48
7楼


回复内容:

对: xiexie1999 回复内容:对: 海娃娃  回复内容:对: xiexie... 内容的回复!

-------------------------

扩展模块供电是通过背板线通过的5V电源供电的,你检查一下是不是线没有插紧,还有最好不要带电进行跟换

江电研

  • 精华:0帖
  • 求助:0帖
  • 帖子:4帖 | 71回
  • 年度积分:40
  • 历史总积分:756
  • 注册:2019年1月15日
发表于:2019-12-17 09:40:34
8楼

线路有没有问题检查一下接线!

海娃娃

  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 30回
  • 年度积分:0
  • 历史总积分:162
  • 注册:2017年3月04日
发表于:2019-12-17 09:55:02
9楼


回复内容:

对: 请叫我王老湿 回复内容:对: xiexie1999  回复内容:对:... 内容的回复!

-------------------------这个4AD-PT模块上有  两个24V电源指示灯    右上角有一个是显示绿色   还有右下角有一个是红色的  现在是灭的     这个模块有外部24v供电  我测量是正常的     还有一个5 V供电是通讯总线提供的     我换的时候都是断电换的    右下角这个24 V指示灯是什么作用


海娃娃

  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 30回
  • 年度积分:0
  • 历史总积分:162
  • 注册:2017年3月04日
发表于:2019-12-17 09:59:08
10楼


回复内容:

对: xiexie1999 回复内容:对: 海娃娃  回复内容:对: xiexie... 内容的回复!

-------------------------这个没有操作过   刚接触PLC  技术比较菜      是直接用编程电缆连接PLC重新写入源程序吗   


海娃娃

  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 30回
  • 年度积分:0
  • 历史总积分:162
  • 注册:2017年3月04日
发表于:2019-12-17 10:03:19
11楼


回复内容:

对: 江电研 线路有没有问题检查一下接线! 内容的回复!

-------------------------线路没有问题    就是每个特殊模块都有一个单元号    我把模块的单元号1 换到了其他控制系统的单元号4上  是不是因为这个原因导致错误  才不变送温度值的?


xiexie1999

  • [版主]
  • 精华:1帖
  • 求助:12帖
  • 帖子:717帖 | 3885回
  • 年度积分:23
  • 历史总积分:160147
  • 注册:2013年4月29日
发表于:2019-12-17 10:12:29
12楼


回复内容:

对: 海娃娃 回复内容:对: xiexie1999  回复内容:对:... 内容的回复!

-------------------------

是的  PLC上的24V接到哪里了?这是PLC内部电源  也有可能电源功率不足

xiexie1999

  • [版主]
  • 精华:1帖
  • 求助:12帖
  • 帖子:717帖 | 3885回
  • 年度积分:23
  • 历史总积分:160147
  • 注册:2013年4月29日
发表于:2019-12-17 10:19:12
13楼


回复内容:

对: 海娃娃 回复内容:对: 江电研  线路有没有问题检查一下接线!... 内容的回复!

-------------------------

模块换了  读取的模块号地址也跟着变了  

李东泽

  • [版主]
  • 精华:7帖
  • 求助:25帖
  • 帖子:1209帖 | 6375回
  • 年度积分:216
  • 历史总积分:44409
  • 注册:2010年3月25日
发表于:2019-12-17 11:23:03
14楼

楼主是带电拔插的模块吗?

如果是那就准备换新的吧

李东泽

  • [版主]
  • 精华:7帖
  • 求助:25帖
  • 帖子:1209帖 | 6375回
  • 年度积分:216
  • 历史总积分:44409
  • 注册:2010年3月25日
发表于:2019-12-17 11:24:36
15楼


引用 海娃娃 的回复内容: 回复内容:对: 江电研  线路有没有问题检查一下接线!...

-------------------------

模块的位置是程序里面写好的,不能随便换位置

海娃娃

  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 30回
  • 年度积分:0
  • 历史总积分:162
  • 注册:2017年3月04日
发表于:2019-12-17 12:03:13
16楼


回复内容:

对: 李东泽 楼主是带电拔插的模块吗?如果是那就准备换新的吧 内容的回复!

-------------------------

拔模块的时候都是PLC断电操作的         换好后再打开电源   

海娃娃

  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 30回
  • 年度积分:0
  • 历史总积分:162
  • 注册:2017年3月04日
发表于:2019-12-17 12:10:15
17楼


回复内容:

对: xiexie1999 回复内容:对: 海娃娃  回复内容:对: 江电研  线... 内容的回复!

-------------------------

PLC里面的主程序应该不会变吧  可能会出现错误    但是换回原来的模块为什么也读不出来呢   我看4AD-PT模块的BFM #1-#4是检测模块错误的   如果电源错误   或者接的温度探头错误   错误消除后应该会恢复正常显示的吧

海娃娃

  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 30回
  • 年度积分:0
  • 历史总积分:162
  • 注册:2017年3月04日
发表于:2019-12-17 12:22:09
18楼


回复内容:

对: 李东泽 引用 海娃娃 的回复内容: 回复内容:对: 江电研  ... 内容的回复!

-------------------------

之前不知道  就尝试的换了一下模块   结果悲剧了   温度不显示了   然后查资料才知道  不能随便更换模块   所以现在请教大神要怎么拯救   才能恢复正常?     要怎么操作

回复内容:

对: 李东泽 引用 海娃娃 的回复内容: 回复内容:对: 江电研  ... 内容的回复!

-------------------------


xiexie1999

  • [版主]
  • 精华:1帖
  • 求助:12帖
  • 帖子:717帖 | 3885回
  • 年度积分:23
  • 历史总积分:160147
  • 注册:2013年4月29日
发表于:2019-12-17 13:35:41
19楼


回复内容:

对: 海娃娃 回复内容:对: xiexie1999  回复内容:对:... 内容的回复!

-----------------------应该是可以 也有可能错误没有完全消除  可以清掉PLC里面再重新下载

海娃娃

  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 30回
  • 年度积分:0
  • 历史总积分:162
  • 注册:2017年3月04日
发表于:2019-12-17 18:08:18
20楼


回复内容:

对: xiexie1999 回复内容:对: 海娃娃  回复内容:对: xiexie... 内容的回复!

-------------------------好的   我再重新写一遍程序试试  看能不能恢复正常     非常感谢给的建议



热门招聘
相关主题

官方公众号

智造工程师
    首页 上一页 1 2 下一页 尾页