西门子博图cpu固件版本与硬件不一致 点击:560 | 回复:11



一不缺

    
  • 精华:0帖
  • 求助:1帖
  • 帖子:1帖 | 45回
  • 年度积分:95
  • 历史总积分:1005
  • 注册:2016年2月24日
发表于:2021-03-07 16:19:57
楼主
求助帖50分-已结帖

之前还好好的。很长一段时间没用了,今天弄了个小程序进去试试,下载后程序进去了,然后报错。erroa。报警信息是在线固件版本4.4,离线版本4.2.    然后博图里同型号固件版本是4.2.这问题是需要我升级博图固件版本吗?

点击里固件更新又提示最新版本???有点懵




一不缺

  • 精华:0帖
  • 求助:2帖
  • 帖子:2帖 | 49回
  • 年度积分:57
  • 历史总积分:967
  • 注册:2016年2月24日
发表于:2021-03-08 17:58:20
1楼

最后这sf灯闪的问提这么处理了,本想看能不能把plc固件版本刷下来,去西门子官网按4楼提供的链接下载cpu版本对应的4.2固件版本,然后提示需要注册/////这注册太麻烦了点。。。。。。然后我连接了plc,在cpu中把cpu恢复出厂设置,然后重新导入程序,选在下载模式只改软件部分 

柳红岩

  • 精华:1帖
  • 求助:5帖
  • 帖子:11帖 | 505回
  • 年度积分:47
  • 历史总积分:11032
  • 注册:2009年8月05日
发表于:2021-03-07 17:25:50
2楼

即使固件版本不相同  下载程序和运行也没有问题的。

你的错误截图发上来看看呢。或许不是这个问题


什么版本的CPU?4.2 4.4来看应该是1200把

yang20908

  • 精华:0帖
  • 求助:0帖
  • 帖子:1帖 | 730回
  • 年度积分:121
  • 历史总积分:5040
  • 注册:2010年4月06日
发表于:2021-03-07 17:57:20
3楼

不影响使用的前提下可以忽略

请叫我王老湿

  • [版主]
  • 精华:0帖
  • 求助:0帖
  • 帖子:607帖 | 6844回
  • 年度积分:258
  • 历史总积分:203415
  • 注册:2011年4月25日
发表于:2021-03-08 08:41:21
4楼

你的PLC是不是之前用了高版本软件下载过程序?

Allen010

  • 精华:0帖
  • 求助:0帖
  • 帖子:17帖 | 210回
  • 年度积分:1597
  • 历史总积分:3669
  • 注册:2010年8月04日
发表于:2021-03-08 13:35:30
5楼

1、固件更新是有限制的,并不是所有固件均可以通过固件升级包处理,必要时还是需要安装高版本软件解决。

V4.4与V4.2这个无法通过固件升级处理,解决V4.2的版本升级,只能通过安装高版本的portal软件。固件升级版本,如V4.2,升级固件后的版本形式V4.2.1。而无法改变V4.2这个2字为3或4

2、设备应用的plc版本低,而新购买的plc版本高,没有关系的,高版本的plc照样能够下载低版本时编辑的用户程序。反过来是不行了的。

 下载时注意:PLC本体上的固件版本比软件组态版本固件版本高,也可以直接下载程序进去;只需要点击plc右键,编译选项里的”软件完全重构“和”硬件完全重构“都重新编译一下,就可以了


3、可以再确认下error产生的原因。西门子论坛中,有个类似的问题,上面那两点是答复。

https://www.ad.siemens.com.cn/service/answer/solved_245141_1072.html

一不缺

  • 精华:0帖
  • 求助:2帖
  • 帖子:2帖 | 49回
  • 年度积分:57
  • 历史总积分:967
  • 注册:2016年2月24日
发表于:2021-03-08 16:41:51
6楼

一不缺

  • 精华:0帖
  • 求助:2帖
  • 帖子:2帖 | 49回
  • 年度积分:57
  • 历史总积分:967
  • 注册:2016年2月24日
发表于:2021-03-08 17:10:19
7楼

"yang20908" 的回复,发表在2楼
        对内容: 【不影响使用的前提下可以忽略】进行回复:

        -----------------------------------------------------------------


sf灯之闪

一不缺

  • 精华:0帖
  • 求助:2帖
  • 帖子:2帖 | 49回
  • 年度积分:57
  • 历史总积分:967
  • 注册:2016年2月24日
发表于:2021-03-08 17:11:05
8楼

"请叫我王老湿" 的回复,发表在3楼
        对内容: 【你的PLC是不是之前用了高版本软件下载过程序?】进行回复:

        -----------------------------------------------------------------


没有  我也 是奇了怪了  ,2月前用的时候都是好好的

tendinggrass

  • 精华:0帖
  • 求助:0帖
  • 帖子:4帖 | 36回
  • 年度积分:23
  • 历史总积分:1129
  • 注册:2012年6月07日
发表于:2021-03-27 07:49:58
9楼

软件要更新固件,在官网下载对应版本的HSP进行升级

william

  • 精华:0帖
  • 求助:0帖
  • 帖子:0帖 | 0回
  • 年度积分:130
  • 历史总积分:150
  • 注册:2020年8月13日
发表于:2021-03-30 16:58:02
10楼

刷固件版本,刷成一样的就好了,刷机的时候千万不要断电,一旦断电你就得寄给供应商让他们给你操作了

Smile-lyc

  • [版主]
  • 精华:179帖
  • 求助:46帖
  • 帖子:4063帖 | 20263回
  • 年度积分:2151
  • 历史总积分:110712
  • 注册:2006年8月04日
发表于:2021-04-08 11:19:38
11楼

感谢求助者和答疑者对求助答疑板块的厚爱,赠人玫瑰,手留余香。

对于求助者要求:

1、请在一个月内自行结贴,把悬赏积分(如果设置积分悬赏求助)发放给答疑者;

2、如果在求助答疑过程中,自己已经有效解决问题,建议大家把解决问题方法在自己求助帖分享,有效分享可以获得50积分奖励。



相关主题

官方公众号

智造工程师