首页 上一页 1 2 下一页 尾页

哪位高人指点一二开关电源UC2844无输出 点击:28136 | 回复:35



zymbyd

    
  • 精华:1帖
  • 求助:10帖
  • 帖子:14帖 | 28回
  • 年度积分:502
  • 历史总积分:595
  • 注册:2014年7月07日
发表于:2015-05-06 15:54:10
楼主
求助帖10分-未结帖

一设备开关电源PWM芯片用的是2844B无输出.供电后测量其7脚供电电压在11-13V左右拨动,电源电路全部通查除变压器无法断定好坏其它都没问题,怀疑g2844供电过低于是断开原电路供电,外部单给2844的7脚供一路16V电压,试机电源工作正常,各路输出正常.事实证明电源电路应该是没问题,问题是启动电压过低造成的,于是把启动电阻变小,此机是用4个44K在串一个二极管形成的启动电路.我短接一个电阻不起,短接两个还是不起,把启动电容加的很大后输出一闪一闪的,,测量启动电压上升到15.3左右电压立刻降下,如此反复.我以前碰到过类似的我把启动电阻变小就起可是此机我短了两个电阻还是不起换了好多器件就是不行,有哪位高手帮我分析下指点下




gsja

  • 精华:0帖
  • 求助:1帖
  • 帖子:7帖 | 170回
  • 年度积分:76
  • 历史总积分:752
  • 注册:2008年8月22日
发表于:2015-05-12 11:26:41
1楼

兄弟,不要乱改原电路,如果以前电路能正常工作,肯定是出问题了,而不是元器件大小的问题。你对开关电源的工作原理还是不太清楚。一般2844的供电是需要开关电源起振后二次供的,只有起振后供电脚电压才能稳定。所以要找电源不起振的原因,一般有几种可能,

1。负载短路;2.稳压反馈有问题;3.开关变压器损坏。4.开关管有问题。具体还要看电路工作原理,慢慢查找。建议你好好研究以下开关电源的工作原理……

zymbyd

  • 精华:1帖
  • 求助:10帖
  • 帖子:14帖 | 28回
  • 年度积分:502
  • 历史总积分:595
  • 注册:2014年7月07日
发表于:2015-05-12 15:55:52
2楼

兄弟啊你说的没错.但如你所说的4点可能性我都查了没问题.因为我把原有的启动电阻摘掉一个,用外部瞬间给个16V电源工作正常,如果你说的4点有一点有问题即使外部瞬间给启动电压也不会正常工作的.在帮我好好分析分析.变压器我也换过了.

gsja

  • 精华:0帖
  • 求助:1帖
  • 帖子:7帖 | 170回
  • 年度积分:76
  • 历史总积分:752
  • 注册:2008年8月22日
发表于:2015-05-12 18:45:12
3楼

你是说用外部供电,开关电源起振了?次级有电压输出?并且次级电压都正常?如果是这样保护电路也正常,可以肯定问题在稳压反馈和反馈供电,1.将反馈供电整流二极管换掉,有时二极管性能不良不容易测;将启动电容换回原值,太大充电时间长不利于再次启动。还要检查二极管并联的瓷片电容是否正常;

2.将431和光耦换掉,这些原件不好测;

3.检测2844的2脚电压反馈和3脚电流检测,看值是否正常

  我觉得好像是反馈供电的问题,你外部供电启动时可测二次供电电压是否正常?

实在不行换个2844吧,没有就用3844

gsja

  • 精华:0帖
  • 求助:1帖
  • 帖子:7帖 | 170回
  • 年度积分:76
  • 历史总积分:752
  • 注册:2008年8月22日
发表于:2015-05-12 18:55:48
4楼

我说的是8脚封装非14脚封装

zymbyd

  • 精华:1帖
  • 求助:10帖
  • 帖子:14帖 | 28回
  • 年度积分:502
  • 历史总积分:595
  • 注册:2014年7月07日
发表于:2015-05-12 23:19:56
5楼

我用外部瞬时给启动电压电源起震了,然后断掉外部启动电压,电源工作正常且电源输出电压都正常。这样我想是不是应该能够排除你说的稳压反馈与反馈供电电路。我想如果稳压反馈电路有问题即使用外部电压启动但是它的输出电压会有所反应或高或低等。如果反馈供电有问题我用瞬间启动电压启动后,然后断掉外部启动电源开关电源就应该停止震荡了,但我断掉后工作正常,此机原用3844后来我换了还是不行,又用的2844反应一样。其实故障点我猜测就是启动电压不足,或是电流不够,但是我改动启动电阻应该会好的,但是就是不行,在手半月了急啊!启动电路是4个44.2K电阻和一个二极管

gsja

  • 精华:0帖
  • 求助:1帖
  • 帖子:7帖 | 170回
  • 年度积分:76
  • 历史总积分:752
  • 注册:2008年8月22日
发表于:2015-05-13 10:41:49
6楼

根据你说的,看起来就在启动电源部分。通电启动电压波动说明电源想启动,但启动后二次供电不足,二次供电一般取开关变压器一绕组经整流滤波可可得,一般2844的首次启动电压较高,正常工作后维持电压相对低些,所以可能二次供电电压偏低,将二次供电整流二极管换掉,有时二极管性能不良不容易测;将启动电容换回原值,太大充电时间长不利于再次启动。还要检查二极管并联的瓷片电容是否正常;

  个人认为二极管性能不良可能性较大。首次启动靠得是启动电容放电,所以只要启动电容容值正常,就能正常工作,不要再考虑充电电阻和启动电容了

gsja

  • 精华:0帖
  • 求助:1帖
  • 帖子:7帖 | 170回
  • 年度积分:76
  • 历史总积分:752
  • 注册:2008年8月22日
发表于:2015-05-13 10:46:59
7楼

顺便说一下更换的二极管一定要是快速恢复的

zymbyd

  • 精华:1帖
  • 求助:10帖
  • 帖子:14帖 | 28回
  • 年度积分:502
  • 历史总积分:595
  • 注册:2014年7月07日
发表于:2015-05-13 13:53:18
8楼

你的分析有道理.我也想了下,当我把启动电容加大后,电源能起只是震荡试的,但至少正明启动电压能够让2844启动工作,至于一下一下的应该就是你说的反馈供电的电压满足不了2844的工作电压需求.但矛盾的是我用外给电压时若反馈供电电路有问题的话应该也不能够工作才是,我给的是瞬间启动电压并非持续的,后续的供电仍是反馈供电电路提供的.不过还的按你指点的把二极管换掉试试

zymbyd

  • 精华:1帖
  • 求助:10帖
  • 帖子:14帖 | 28回
  • 年度积分:502
  • 历史总积分:595
  • 注册:2014年7月07日
发表于:2015-05-13 22:50:38
9楼

结果很骨感啊,还是不行啊。用原电路启动反馈供电只有15V左右摆动,用外启动电压供电反馈电压却有19V,我已经把二极管换了。无极电容也量了。还得帮我啊

gsja

  • 精华:0帖
  • 求助:1帖
  • 帖子:7帖 | 170回
  • 年度积分:76
  • 历史总积分:752
  • 注册:2008年8月22日
发表于:2015-05-14 10:15:28
10楼

确实很棘手,我怀疑开关管激励不足,查一下g(b)极驱动电阻是否变质,d(c)极尖峰吸收回路的二极管和电容是否正常,将s极与地之间的过流检测电阻短接试一下,

实在不行换一个开关管试一下。

顺便量一下2脚3脚工作时的电压值

zymbyd

  • 精华:1帖
  • 求助:10帖
  • 帖子:14帖 | 28回
  • 年度积分:502
  • 历史总积分:595
  • 注册:2014年7月07日
发表于:2015-05-14 13:46:27
11楼

开关管早已换过.驱动电阻是100欧没问题.吸收回路电容及二极管均没有漏电迹象,过流检测电阻短接倒是没试过.我试下

第五纪冰川

  • 精华:3帖
  • 求助:5帖
  • 帖子:43帖 | 4204回
  • 年度积分:69
  • 历史总积分:11975
  • 注册:2005年2月18日
发表于:2015-05-14 22:20:21
12楼

首先换掉2844,然后检查2844供电电容的漏电。

zymbyd

  • 精华:1帖
  • 求助:10帖
  • 帖子:14帖 | 28回
  • 年度积分:502
  • 历史总积分:595
  • 注册:2014年7月07日
发表于:2015-05-15 14:06:26
13楼

2844早已更换电容也早换了

第五纪冰川

  • 精华:3帖
  • 求助:5帖
  • 帖子:43帖 | 4204回
  • 年度积分:69
  • 历史总积分:11975
  • 注册:2005年2月18日
发表于:2015-05-15 21:54:29
14楼

回复内容:

对: zymbyd 2844早已更换电容也早换了 内容的回复!

 有示波器没有,捕捉一次2844启动过程中的电源电压。看下负载是否太重或太轻。

如果有条件你测试一下2844的电源电流消耗,不排除你换的2844性能不好。

此问题我遇到过,非常棘手,后来解决。明天我查一下记录。

2844电源电容如果偏小会遇到一个问题,达到启动电压后,芯片启动工作会消耗较大能量,如果电容存储的能量不够,而副边电源又没有及时建立起来,电容上的电压降低到关闭电压,芯片关闭。然后充电电阻再次充电,,,,循环往复。

你看下2844的芯片资料,计算下。

第五纪冰川

  • 精华:3帖
  • 求助:5帖
  • 帖子:43帖 | 4204回
  • 年度积分:69
  • 历史总积分:11975
  • 注册:2005年2月18日
发表于:2015-05-16 11:11:12
15楼

负载过轻(如空载),或软启动时间过长.导致启动电容上能量消耗过多,而副边电压过低(脉宽太小(电压反馈来自负边负载绕组),或副边电压未能完全建立起来,都会导致这个现象产生。

zymbyd

  • 精华:1帖
  • 求助:10帖
  • 帖子:14帖 | 28回
  • 年度积分:502
  • 历史总积分:595
  • 注册:2014年7月07日
发表于:2015-05-16 15:02:01
16楼
不行了我受不了了,今天又折腾了一上午,还是一样思虑再三选择放弃。电源的件不说全换了也差不多,第一次电源的问题没有修好,虽有不甘却又无能为力,这种感觉真是不爽。在此感谢gsja与第五纪冰川几日所提供的经验与思。路上的帮助有你们维修的路上不再枯燥。

第五纪冰川

  • 精华:3帖
  • 求助:5帖
  • 帖子:43帖 | 4204回
  • 年度积分:69
  • 历史总积分:11975
  • 注册:2005年2月18日
发表于:2015-05-16 21:17:00
17楼

回复内容:

对: zymbyd 不行了我受不了了,今天又折腾了一上午,还是一样思虑再三... 内容的回复!

 不要着急,明天休息一天,后天接着搞。

前年我遇到过一次雷达站地空通讯系统监控器的电源,有时无法开机,有时开机成功不定期出问题,也许2天,也许半个小时。电源有多组输出,有芯片对这些电源电压进行监控,知道是出现了保护,也是能换的基本都换了,而换的都没有发现坏。搞了以为问题解决,人家拿去过几天就又出问题,搞了好几次,估计有半个月,最后也是给我累趴下了。换新!

这是我遇到的第一个“非主控芯片”损坏而未能成功修复的电子设备!

那个坏的电源我保留下来了,有时间再折腾下。

zymbyd

  • 精华:1帖
  • 求助:10帖
  • 帖子:14帖 | 28回
  • 年度积分:502
  • 历史总积分:595
  • 注册:2014年7月07日
发表于:2015-05-16 22:14:21
18楼

看来你真是高手啊,你说的那个雷达站地空通讯系统电源我想想名字就恐惧,那些进口的电源设计很复杂电路结构原理很是不易解析。你的工作是修哪方面的

gsja

  • 精华:0帖
  • 求助:1帖
  • 帖子:7帖 | 170回
  • 年度积分:76
  • 历史总积分:752
  • 注册:2008年8月22日
发表于:2015-05-16 23:13:55
19楼

在开关变压器上绕上3--5圈漆包线单独给二次供电提供电源,看是不是供电问题

第五纪冰川

  • 精华:3帖
  • 求助:5帖
  • 帖子:43帖 | 4204回
  • 年度积分:69
  • 历史总积分:11975
  • 注册:2005年2月18日
发表于:2015-05-17 09:47:15
20楼

回复内容:

对: zymbyd 看来你真是高手啊,你说的那个雷达站地空通讯系统电源我想... 内容的回复!

 gsja才是高手。

我修理是业余爱好,学的是电子,工作是搞工控,三不两时挣点外快。


相关主题

官方公众号

智造工程师
首页 上一页 1 2 下一页 尾页